summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsearpc')
-rw-r--r--net-libs/libsearpc/libsearpc-3.0.8-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.0.8-r1.ebuild b/net-libs/libsearpc/libsearpc-3.0.8-r1.ebuild
new file mode 100644
index 000000000000..70f1c5fd0f9a
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.0.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vcs-snapshot
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1"
+RDEPEND="${DEPEND}
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}