summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest2
-rw-r--r--net-libs/nghttp2/nghttp2-1.38.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 8acfd1254889..f98abcad1ef5 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,5 @@
DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270bc3079972885a1f707a9cc4ebb053f7347930ce217d2cf4277eab0a3309accb8f9ff18bd8ccc55c86aefa6246c3 SHA512 eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74
DIST nghttp2-1.36.0.tar.xz 1629020 BLAKE2B 7c116988c22801688c50d6d514ddb904920cc54d3c3d141137e6ed8b2182ef4e670f0a0fdebaeabfe0df8cdea4cfd1ee3fb083628f035201f104de6f3614dd25 SHA512 4e0d5c5cdb4f1b7e5f12790850237f36649af4aa9596033392725972e4e0e5a33bb78bd1aa0735e35e489b523b7e9a236a7b5847dfca69bd7583fcab36c13c76
DIST nghttp2-1.37.0.tar.xz 1628248 BLAKE2B ed5cdfda44b4e38a03d92352520eb765cc1da99080e0cd3e9d663efd5ef2ff219c6ccdbc16cfde001a8377afc796acef250913e1eb422ae2cac2eb95b8f98089 SHA512 67a4b9df3f7f0edad719011fa289d9aa9ef04f31ef3ccf826b861c8830ed24e0743a33b54ab66d198fec7edbf723852b38a2007b335d7f566f702f4b02297b0f
+DIST nghttp2-1.38.0-unbundle_http_parser.patch.xz 2616 BLAKE2B 3f15154d33f32c91aad87f23f56d761501e19e0b53b99d4df720f9e04d6d9c49a52118acbe3da87f8585c2b71b7b430ef60fc33465605f3bf9933635aabb924d SHA512 1b4377b34cf6428164011be9fc86efdd7ab8d3443edf197c45768beea0f843084a842c4cb2abc5179d6036ec99174557e06344ce67a07d98992de64d99faf3a6
+DIST nghttp2-1.38.0.tar.xz 1628356 BLAKE2B 0568d4ac5c1e5e6d7adf762815836502524d59fb55c623f344a8427638407a19447fe1a7753142aa205898f7bda6ebce8ef6f4d85edc6da98ffa98b83d4e363e SHA512 e432d52bcf77379ed5c10ceafb587ec8d66c56bb728cda56487b237cbab1d0073689624419ed306162dab3a51b91cfe0f59cb173b5d81346e2b6d0abd56635bc
diff --git a/net-libs/nghttp2/nghttp2-1.38.0.ebuild b/net-libs/nghttp2/nghttp2-1.38.0.ebuild
new file mode 100644
index 000000000000..9b47d5f44b53
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.38.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+# 675772
+SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PN}-1.38.0-unbundle_http_parser.patch.xz"
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ >=net-libs/http-parser-2.9.1:=
+ )
+ hpack-tools? (
+ >=dev-libs/jansson-2.5
+ >=net-libs/http-parser-2.9.1:=
+ )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-1.38.0-unbundle_http_parser.patch"
+)
+
+src_prepare() {
+ default
+ # Remove bundled stuff
+ rm -r third-party/http-parser || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-python-bindings
+ --disable-werror
+ --without-bundled-http_parser
+ --without-cython
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}