summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/files/0001-Use-loopback-IP-address-rather-than-name.patch62
-rw-r--r--net-mail/notmuch/notmuch-0.28.3.ebuild210
3 files changed, 273 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index af2d00725b08..598baf92cf0e 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -5,3 +5,4 @@ DIST notmuch-0.25.3.tar.gz 883151 BLAKE2B 511f93c310e8b82f1b629735cbe626ab1ba8ea
DIST notmuch-0.26.1.tar.gz 906523 BLAKE2B da0b06361d586d84bea5c6e28adf7850dcb119e9f70ae67e06ff1438b9d20f4b04707d3e6ee6e755d569d15b8a720506b4c242c0c84258e8f5c8996caa62fc47 SHA512 f0d95a0f03535495037c73ab18d1251ece505284736efa5a535fe9bc8aea33954b5c87e5dcdfd30670c8df53178294be520a63e5b19beac7d90f166e616d19dd
DIST notmuch-0.26.2.tar.gz 907187 BLAKE2B 81212555d729bd05be2edfb0f3dfd604de9d5f3e99e79ebd24a195441bd3778c7c72abe0b6b569dc1cf2ad9d94af1cbe3ca3aff77f521888b7be2eb08444dde1 SHA512 ebd8460c5f08cb8c79dabc1bc1bc32e1f2e1f123d304bb20205d4dedb982186336fd43d0e39acf020ea2563278bee0a063ceb3bf276f1251c099d8fcdd5098e7
DIST notmuch-0.27.tar.gz 912583 BLAKE2B 75bb13e9666bd2898f58e5ecdd6a180d0da21188665f107857e6729f057525bb7c94832d140de8ff7b3fd31b51e33bcbe5b59d3fc09ba9a854c1c05499df762e SHA512 7c58c6fe5c3b43a979c3a439a24106417120726fd688b456d9084388ddd7c88ab1b6d99cd4676101f085d60bb37099631caa286b76588fcb041bb004ff325515
+DIST notmuch-0.28.3.tar.gz 921920 BLAKE2B 9b96a0cac8188bcaf9efab532721449c655fec4dac77c3eb327e576184cb430aa0fffc9ac74af82ad3ad80097afdda5c8accddbee7e5720d180c071d9dd2ef85 SHA512 dd3931b78cc27540e962f1fca5f4ebb1c04b2637a5761cda023f307fd9be4b5ddc2af26010330868c55200fa96b60b2a11b3b22d4c20d2a4a2d3787421ed85cf
diff --git a/net-mail/notmuch/files/0001-Use-loopback-IP-address-rather-than-name.patch b/net-mail/notmuch/files/0001-Use-loopback-IP-address-rather-than-name.patch
new file mode 100644
index 000000000000..f7e1d7e05e35
--- /dev/null
+++ b/net-mail/notmuch/files/0001-Use-loopback-IP-address-rather-than-name.patch
@@ -0,0 +1,62 @@
+From 9c15b508819d15d0852d71c2e897550cfaac09ba Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20Piotr=20=C5=BBo=C5=82nowski?=
+ <aidecoe@aidecoe.name>
+Date: Thu, 7 Mar 2019 22:47:55 +0000
+Subject: [PATCH] Use loopback IP address rather than name
+
+With FEATURES="network-sandbox" 'localhost' name lookup fails.
+---
+ test/smtp-dummy.c | 8 ++++----
+ test/test-lib.sh | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/smtp-dummy.c b/test/smtp-dummy.c
+index 71992edd..e72ba2d0 100644
+--- a/test/smtp-dummy.c
++++ b/test/smtp-dummy.c
+@@ -76,7 +76,7 @@ process_command (FILE *peer, FILE *output, const char *command)
+ fprintf (peer, "502 not implemented\r\n");
+ fflush (peer);
+ } else if (STRNCMP_LITERAL (command, "HELO ") == 0) {
+- fprintf (peer, "250 localhost\r\n");
++ fprintf (peer, "250 127.0.0.1\r\n");
+ fflush (peer);
+ } else if (STRNCMP_LITERAL (command, "MAIL FROM:") == 0 ||
+ STRNCMP_LITERAL (command, "RCPT TO:") == 0) {
+@@ -105,7 +105,7 @@ do_smtp_to_file (FILE *peer, FILE *output)
+ size_t line_size;
+ ssize_t line_len;
+
+- fprintf (peer, "220 localhost smtp-dummy\r\n");
++ fprintf (peer, "220 127.0.0.1 smtp-dummy\r\n");
+ fflush (peer);
+
+ while ((line_len = getline (&line, &line_size, peer)) != -1) {
+@@ -182,9 +182,9 @@ main (int argc, char *argv[])
+ goto DONE;
+ }
+
+- hostinfo = gethostbyname ("localhost");
++ hostinfo = gethostbyname ("127.0.0.1");
+ if (hostinfo == NULL) {
+- fprintf (stderr, "Unknown host: localhost\n");
++ fprintf (stderr, "Unknown host: 127.0.0.1\n");
+ ret = 1;
+ goto DONE;
+ }
+diff --git a/test/test-lib.sh b/test/test-lib.sh
+index fca5277d..fa8fd5bd 100644
+--- a/test/test-lib.sh
++++ b/test/test-lib.sh
+@@ -320,7 +320,7 @@ emacs_deliver_message ()
+ test_emacs \
+ "(let ((message-send-mail-function 'message-smtpmail-send-it)
+ (mail-host-address \"example.com\")
+- (smtpmail-smtp-server \"localhost\")
++ (smtpmail-smtp-server \"127.0.0.1\")
+ (smtpmail-smtp-service \"25025\"))
+ (notmuch-mua-mail)
+ (message-goto-to)
+--
+2.19.2
+
diff --git a/net-mail/notmuch/notmuch-0.28.3.ebuild b/net-mail/notmuch/notmuch-0.28.3.ebuild
new file mode 100644
index 000000000000..cfb18c051802
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.28.3.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
+ test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+ "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+ !!<app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/gmime-3.0.3:3.0
+ >=dev-libs/xapian-1.4.9:=
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ sys-apps/texinfo
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ crypt? ( dev-libs/gmime:3.0[crypt] )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
+ crypt? ( app-crypt/gnupg dev-libs/openssl ) )
+ valgrind? ( dev-util/valgrind )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+PATCHES=( "${FILESDIR}"/0001-Use-loopback-IP-address-rather-than-name.patch )
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_unpack() {
+ unpack "${P}".tar.gz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # assure that new Makefile.config will be generated
+ rm -f Makefile.config || die
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ rm -r html/_sources || die
+ rm html/{objects.inv,.buildinfo} || die
+ mkdir -p ../html && mv html ../html/python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ if has_version '<dev-libs/xapian-1.4'; then
+ elog "Regular expression searches supported for from: and subject:"
+ elog "require >=dev-libs/xapian-1.4."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}