summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cfengine')
-rw-r--r--net-misc/cfengine/cfengine-3.6.2.ebuild1
-rw-r--r--net-misc/cfengine/files/cfengine-3.6.2-sysmacros.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/net-misc/cfengine/cfengine-3.6.2.ebuild b/net-misc/cfengine/cfengine-3.6.2.ebuild
index a4e5ae6c7db9..025728ee43ea 100644
--- a/net-misc/cfengine/cfengine-3.6.2.ebuild
+++ b/net-misc/cfengine/cfengine-3.6.2.ebuild
@@ -40,6 +40,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
default
epatch "${FILESDIR}/${P}-ifconfig.patch"
+ epatch "${FILESDIR}/${P}-sysmacros.patch"
eautoreconf
}
diff --git a/net-misc/cfengine/files/cfengine-3.6.2-sysmacros.patch b/net-misc/cfengine/files/cfengine-3.6.2-sysmacros.patch
new file mode 100644
index 000000000000..7aa8e2779253
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.6.2-sysmacros.patch
@@ -0,0 +1,19 @@
+Fixes compile on glibc-2.25
+
+Fixes: https://bugs.gentoo.org/612658
+--- cfengine-3.6.2.orig/libutils/platform.h 2014-09-25 04:53:31.000000000 -0700
++++ cfengine-3.6.2/libutils/platform.h 2017-10-20 15:11:15.676360363 -0700
+@@ -360,12 +360,13 @@ void globfree(glob_t *pglob);
+
+ #ifdef __linux__
+ # if defined(__GLIBC__) || defined(__BIONIC__)
+ # include <net/route.h>
+ # include <netinet/in.h>
+ # include <netinet/ip.h>
++# include <sys/sysmacros.h>
+ # else
+ # include <linux/route.h>
+ # include <linux/in.h>
+ # include <linux/ip.h>
+ # endif
+ #endif