summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/miniupnpd')
-rw-r--r--net-misc/miniupnpd/Manifest1
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index 0c5fa692dfeb..affa5b2c967b 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1,3 +1,2 @@
DIST miniupnpd-2.0.20161216.tar.gz 218119 BLAKE2B 9d09f4d2b19c4f808bf527c90a73739baa0eac924f461f6cbbf20866ee851f85248efa920bd6a770173d4a3a8f9e8d771ffacdb17aa684d329295502278f7963 SHA512 af82f060d28033dd670fcc96c8e2895f92d249a8a79d991e0215159eeb57715d7a9152d7d751b836091f7a623ce8a194ea243d1a2fb639349e320c02ce187c27
DIST miniupnpd-2.0.20171212.tar.gz 222617 BLAKE2B 6ac33048b18d9f8aeb5103f57c9982fec956a61155f8592118c38dea70801597d9e867690ef2f1cdfaf848a25d7ddb4891b3ebf37cd391b33518d6b02e6f9b4a SHA512 3ab81c840953736c662bcb6f074421052a846c7827768acd7a961a23906b9e3d3389f5b593fb6f8011c8e717dae6cd3907b6d34e7904d560378671a7fc1dd3b2
-DIST miniupnpd-2.0.tar.gz 217802 BLAKE2B b70a5e36e7315382d68038da479b0dd8bc87ae01acaccbf784413a32a32719bbc0923297bd6b6d2bf1835dd7ebf9161203120942d5c31cd63f178c4ceda1a1db SHA512 c88036d3f4b065fc855572db8945d921641a71a23ffe8b52cb4ccb1a7cf3e7396841c436d54d7ff5968d034d8c4bfc91630719959000436230bb8c37e5bdc8d4
diff --git a/net-misc/miniupnpd/miniupnpd-2.0.ebuild b/net-misc/miniupnpd/miniupnpd-2.0.ebuild
deleted file mode 100644
index 1347a12fbd0e..000000000000
--- a/net-misc/miniupnpd/miniupnpd-2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="MiniUPnP IGD Daemon"
-HOMEPAGE="http://miniupnp.free.fr/"
-SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+leasefile igd2 ipv6 pcp-peer portinuse strict"
-
-RDEPEND=">=net-firewall/iptables-1.4.6:0=[ipv6?]
- net-libs/libnfnetlink:=
- net-libs/libmnl:=
- dev-libs/gmp:0=
- sys-apps/util-linux
- dev-libs/openssl:0="
-DEPEND="${RDEPEND}
- sys-apps/lsb-release"
-
-src_prepare() {
- default
- mv Makefile.linux Makefile || die
-}
-
-src_configure() {
- local -a opts
- opts=(
- --vendorcfg
- $(use igd2 && printf -- '--igd2\n')
- $(use ipv6 && printf -- '--ipv6\n')
- $(use leasefile && printf -- '--leasefile\n')
- $(use portinuse && printf -- '--portinuse\n')
- $(use pcp-peer && printf -- '--pcp-peer\n')
- $(use strict && printf -- '--strict\n')
- )
-
- emake CONFIG_OPTIONS="${opts[*]}" config.h
-}
-
-src_compile() {
- # By default, it builds a bunch of unittests that are missing wrapper
- # scripts in the tarball
- emake CC="$(tc-getCC)" STRIP=true miniupnpd
-}
-
-src_install() {
- emake PREFIX="${ED}" STRIP=true install
-
- newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
- newconfd "${FILESDIR}"/${PN}-conf.d-r1 ${PN}
-}
-
-pkg_postinst() {
- elog "Please correct the external interface in the top of the two"
- elog "scripts in /etc/miniupnpd and edit the config file in there too"
-}