summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxychains/files/proxychains-4.8.1-makefile.patch')
-rw-r--r--net-misc/proxychains/files/proxychains-4.8.1-makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/proxychains/files/proxychains-4.8.1-makefile.patch b/net-misc/proxychains/files/proxychains-4.8.1-makefile.patch
new file mode 100644
index 000000000000..0658838bbb03
--- /dev/null
+++ b/net-misc/proxychains/files/proxychains-4.8.1-makefile.patch
@@ -0,0 +1,42 @@
+--- proxychains-ng-4.8.1/Makefile
++++ proxychains-ng-4.8.1/Makefile
+@@ -22,10 +22,8 @@
+
+ GENH = src/version.h
+
+-CFLAGS += -Wall -O0 -g -std=c99 -D_GNU_SOURCE -pipe
+-NO_AS_NEEDED = -Wl,--no-as-needed
+-LIBDL = -ldl
+-LDFLAGS = -shared -fPIC $(NO_AS_NEEDED) $(LIBDL) -lpthread
++CFLAGS = -Wall -std=c99 -D_GNU_SOURCE
++LIBS = -ldl -lpthread
+ INC =
+ PIC = -fPIC
+ AR = $(CROSS_COMPILE)ar
+@@ -35,11 +33,11 @@
+ LD_SET_SONAME = -Wl,-soname=
+ INSTALL = ./tools/install.sh
+
+-LDSO_PATHNAME = libproxychains4.$(LDSO_SUFFIX)
++LDSO_PATHNAME = libproxychains.$(LDSO_SUFFIX)
+
+ SHARED_LIBS = $(LDSO_PATHNAME)
+ ALL_LIBS = $(SHARED_LIBS)
+-PXCHAINS = proxychains4
++PXCHAINS = proxychains
+ ALL_TOOLS = $(PXCHAINS)
+ ALL_CONFIGS = src/proxychains.conf
+
+@@ -81,10 +79,10 @@
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS_MAIN) $(INC) $(PIC) -c -o $@ $<
+
+ $(LDSO_PATHNAME): $(LOBJS)
+- $(CC) $(LDFLAGS) $(LD_SET_SONAME)$(LDSO_PATHNAME) -o $@ $(LOBJS)
++ $(CC) $(LDFLAGS) -shared $(PIC) $(LD_SET_SONAME)$(LDSO_PATHNAME) -o $@ $(LOBJS) $(LIBS)
+
+ $(ALL_TOOLS): $(OBJS)
+- $(CC) src/main.o src/common.o -o $(PXCHAINS)
++ $(CC) $(LDFLAGS) src/main.o src/common.o -o $(PXCHAINS) $(LIBS)
+
+
+ .PHONY: all clean install install-config install-libs install-tools