summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pyhoca-gui')
-rw-r--r--net-misc/pyhoca-gui/Manifest1
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/pyhoca-gui/Manifest b/net-misc/pyhoca-gui/Manifest
index d60195f0400a..2f9ee5844827 100644
--- a/net-misc/pyhoca-gui/Manifest
+++ b/net-misc/pyhoca-gui/Manifest
@@ -1 +1,2 @@
DIST pyhoca-gui-0.5.0.7.tar.gz 1345182 BLAKE2B 4986c1d19663ed3df29992cb7b442bed4fc95bdd6e0f1d3521e1bc3d2ab0d98aa9578a470995ab0b28ba13fb29fdb8c384a59f09d08270dd1d689177a9548045 SHA512 bfb0eb95a87e19ff84fd13c642725be40369ec8e7f58615301033d22e3c1f81ed8b47542989711b1ee9414382989c8e258fa24f3f3c6cb950c42a53a9a6bd8b6
+DIST pyhoca-gui-0.5.0.8.tar.gz 2064483 BLAKE2B 63bca5be8673ef4e274caf4e0813b73f5dc8af7818b7638b2ac7411bb1598272bab573bc55c6c5e48fc45cc185bad907594b99ee0c96546683ecd8dd1ef1e3f1 SHA512 35bcbe35056d718ec5b58733b8569fd40cd6843a6661cc19deed02287cf65e03b4812fc82bdb0d54b12a78d5547456463e8adf236d4a7f04e11d0d462fe3eded
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.8.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.8.ebuild
new file mode 100644
index 000000000000..633abd8f8d76
--- /dev/null
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go graphical client applet"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycups[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+}