summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rwbs/rwbs-0.27-r1.ebuild')
-rw-r--r--net-misc/rwbs/rwbs-0.27-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/rwbs/rwbs-0.27-r1.ebuild b/net-misc/rwbs/rwbs-0.27-r1.ebuild
new file mode 100644
index 000000000000..94b40927c68f
--- /dev/null
+++ b/net-misc/rwbs/rwbs-0.27-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Roger Wilco base station"
+HOMEPAGE="http://rogerwilco.gamespy.com/"
+SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+
+SLOT="0"
+LICENSE="Resounding GPL-2"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+# Everything is statically linked
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/rwbs"
+
+src_install() {
+ dodoc README.TXT CHANGES.TXT
+ exeinto /opt/bin
+ doexe rwbs run_rwbs
+
+ # Put distribution into /usr/share/rwbs
+ insinto /usr/share/rwbs/
+ doins "${S}"/anotherpersonjoined "${S}"/helloandwelcome \
+ "${S}"/ifucanhearthis "${S}"/invitetestxmit "${S}"/join?.rwc \
+ "${S}"/plsstartagame "${S}"/thisisatestmsg
+
+ newconfd "${FILESDIR}"/rwbs.conf rwbs
+ newinitd "${FILESDIR}"/rwbs.rc rwbs
+}