summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sshrc')
-rw-r--r--net-misc/sshrc/Manifest1
-rw-r--r--net-misc/sshrc/sshrc-0.6.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/sshrc/Manifest b/net-misc/sshrc/Manifest
index 0d1c7a704a82..120746ca6cb5 100644
--- a/net-misc/sshrc/Manifest
+++ b/net-misc/sshrc/Manifest
@@ -1 +1,2 @@
DIST sshrc-0.6.1.tar.gz 3701 BLAKE2B 36cdd0d4dcc80ea1884533f71e6090a6cb393dc1131a6d78fddc43c37e0597aee2da8b92789a59100ad6941d8c17e6ccbf796d73ec704df45aa768cfc6bf36a7 SHA512 69e0919bdef0ec6fb187814f1a0dd360b331dc4c0fc047f7767399944eccb949c172682331e6ebe940c275f0a2b6293a66a6018e12351f566638eed1ac362d64
+DIST sshrc-0.6.2.tar.gz 4410 BLAKE2B 982ae3f0a6d3727699cc3cd7ddc20304ad1330b165f7450047f7d3b236ba7f3b297223d88c6ce8e00d0db97d3193c4547d7a10d51e8feb3bb639b6276865a8e8 SHA512 79dd964c5ed825b38aa775d35df6adc0857817c418fa4ae1971378f062536035bd66e4faa0fb84f66504f09c7e6368355f8c57036bea8d269b4d9084af95ddc4
diff --git a/net-misc/sshrc/sshrc-0.6.2.ebuild b/net-misc/sshrc/sshrc-0.6.2.ebuild
new file mode 100644
index 000000000000..b97009265ac1
--- /dev/null
+++ b/net-misc/sshrc/sshrc-0.6.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bring your .bashrc, .vimrc, etc. from your local machine when you ssh"
+HOMEPAGE="https://github.com/Russell91/sshrc"
+SRC_URI="https://github.com/Russell91/sshrc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mosh"
+
+RDEPEND="
+ virtual/ssh:0=
+ mosh? ( net-misc/mosh:0[client] )
+"
+
+src_install()
+{
+ dobin sshrc
+ use mosh && dobin moshrc
+}