summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/stargazer/files/patches/stg-2.408-radius-upstream.patch')
-rw-r--r--net-misc/stargazer/files/patches/stg-2.408-radius-upstream.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/stargazer/files/patches/stg-2.408-radius-upstream.patch b/net-misc/stargazer/files/patches/stg-2.408-radius-upstream.patch
new file mode 100644
index 000000000000..790cc3a91e1e
--- /dev/null
+++ b/net-misc/stargazer/files/patches/stg-2.408-radius-upstream.patch
@@ -0,0 +1,31 @@
+--- projects/rlm_stg/Makefile.org 2013-01-18 16:17:18.000000000 +0200
++++ projects/rlm_stg/Makefile 2013-01-18 16:19:13.000000000 +0200
+@@ -57,16 +57,28 @@
+
+ install-bin:
+ ifeq ($(DEBUG), yes)
++ifeq ($(OS), linux)
+ install -D -m $(BIN_MODE) -o $(OWNER) $(PROG) $(PREFIX)/usr/lib/freeradius/$(PROG)
+ else
++ install -D -m $(BIN_MODE) -o $(OWNER) $(PROG) $(PREFIX)/usr/lib/$(PROG)
++endif
++else
++ifeq ($(OS), linux)
+ install -D -m $(BIN_MODE) -o $(OWNER) -s $(PROG) $(PREFIX)/usr/lib/freeradius/$(PROG)
++else
++ install -D -m $(BIN_MODE) -o $(OWNER) -s $(PROG) $(PREFIX)/usr/lib/$(PROG)
++endif
+ endif
+ $(MAKE) -C $(DIR_LIBSRC) install
+
+ uninstall: uninstall-bin
+
+ uninstall-bin:
++ifeq ($(OS), linux)
+ rm -f $(PREFIX)/usr/lib/freeradius/$(PROG)
++else
++ rm -f $(PREFIX)/usr/lib/$(PROG)
++endif
+
+ ifneq ($(MAKECMDGOALS),distclean)
+ ifneq ($(MAKECMDGOALS),clean)