summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/Manifest1
-rw-r--r--net-misc/wget/wget-1.20.1.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 689914076bd9..7b8ec72207bd 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,2 +1,3 @@
DIST wget-1.19.5.tar.gz 4455797 BLAKE2B 988b80090ff1f62cb527afb33c03b7c6a68bbc1649d42f62061e05e416bebf5b2e9546ebafad3c9cdbf1199a8d2b84f4427c921f23338b02631da357da9b3d61 SHA512 0d4964e0f5adb0c023edc831bde9c9f13f3222f6efc1ce93250d234ab937e92b53921624532fb0e6586151ddfdee6df9a7ca91a2a99b3d16e2e68401c625301b
+DIST wget-1.20.1.tar.gz 4392853 BLAKE2B 5740fa70064e24a699ba5fc0b6262b372fc877e86fc74bede07bcfe7dcdf6d4a15db7686fc900d8ec90ad3adce8c4af1c00460601c1845da7907f929d8d48447 SHA512 855c7e3c45f9020a9fdb30e286ee6a0bdcaa780be3d0dda9ffdae73b562ae1012d4550242f66240407a28076a7054328d4f08a469a0da227a9e3410b8d5f46dc
DIST wget-1.20.tar.gz 4474641 BLAKE2B f9a1fdb1299dcee36467e6a78fc90fb8b17b71d14079b5ce6d60a19a27a2bd4c53fdbd3660cbd2d94a3523d4c5ea517e52f46e4af1be60db885fe79a376b3720 SHA512 2e50b9e83c22cb342d85981f89253d9c72bb1a48152c17c4c0b6315683890075f60ad2783e4fa8c2a6d15c53820d9ecb8d0c4b81cfcef4fcc66126ed1cb7ff54
diff --git a/net-misc/wget/wget-1.20.1.ebuild b/net-misc/wget/wget-1.20.1.ebuild
new file mode 100644
index 000000000000..912dcc731412
--- /dev/null
+++ b/net-misc/wget/wget-1.20.1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="https://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
+REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+
+# Force a newer libidn2 to avoid libunistring deps. #612498
+LIB_DEPEND="
+ idn? ( >=net-dns/libidn2-0.14[static-libs(+)] )
+ pcre? ( dev-libs/libpcre2[static-libs(+)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+ )
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )
+ test? (
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Message
+ dev-perl/IO-Socket-SSL
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # revert some hack that breaks linking, bug #585924
+ if [[ ${CHOST} == *-darwin* ]] \
+ || [[ ${CHOST} == *-solaris* ]] \
+ || [[ ${CHOST} == *-uclibc* ]] \
+ || [[ ${CHOST} == *-cygwin* ]] \
+ ; then
+ sed -i \
+ -e 's/^ LIBICONV=$/:/' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+
+ # There is no flag that controls this. libunistring-prefix only
+ # controls the search path (which is why we turn it off below).
+ # Further, libunistring is only needed w/older libidn2 installs,
+ # and since we force the latest, we can force off libunistring. #612498
+ local myeconfargs=(
+ --disable-assert
+ --disable-pcre
+ --disable-rpath
+ --without-included-libunistring
+ --without-libunistring-prefix
+ $(use_enable debug)
+ $(use_enable idn iri)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable pcre pcre2)
+ $(use_enable ssl digest)
+ $(use_enable ssl opie)
+ $(use_with idn libidn)
+ $(use_with ssl ssl $(usex gnutls gnutls openssl))
+ $(use_with uuid libuuid)
+ $(use_with zlib)
+ )
+ ac_cv_libunistring=no \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED%/}"/etc/wgetrc \
+ "${ED%/}"/usr/share/man/man1/wget.1 \
+ "${ED%/}"/usr/share/info/wget.info \
+ || die
+}