summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/babeld/Manifest2
-rw-r--r--net-misc/babeld/babeld-1.9.1.ebuild (renamed from net-misc/babeld/babeld-1.8.0.ebuild)3
-rw-r--r--[-rwxr-xr-x]net-misc/babeld/files/babeld4
3 files changed, 5 insertions, 4 deletions
diff --git a/net-misc/babeld/Manifest b/net-misc/babeld/Manifest
index fd28ca5ff26a..a4867c6f689b 100644
--- a/net-misc/babeld/Manifest
+++ b/net-misc/babeld/Manifest
@@ -1,2 +1,2 @@
-DIST babeld-1.8.0.tar.gz 92124 BLAKE2B 43f24c64280597201880a257095235447a49b97e7fcfc4f53db1c6e45564e41dc751017ce664779e4accdf03cb134cb33856288e2deebc6f194ae1e3744bad4e SHA512 6665ea5108200fe9d158a221ee5697c35fa1bf1d59e99a354aabea844342505731d77c1e3dff3917d048c2154bbadcdda5904ad6e46f16c43f52b5c297480b7d
DIST babeld-1.8.2.tar.gz 92852 BLAKE2B ddf64558ebe2c96812e0b68382cda118539a1221fa15df7ee5d6aa67cdb5e1da556e4518371580bfb9df61780f559892787057605a02b8870c0a8e1f2018fc5d SHA512 08ef0747a672e7a3f2e06d4082da0d021378cea94633fdddf7de38178552bc5a587852fdb5c8bfdeeb6897ba4fd61c78e6ee4d19523a6c3e60d0e3c150418319
+DIST babeld-1.9.1.tar.gz 94668 BLAKE2B 169932e8d37d683bfa7e945e313d17c3ee633d11031d940ef3f5be3e0a9fbaffb28d47cf9f6d6ef6b25130af9a485ac4a629d0009485021d6f2fe19ec5382788 SHA512 433a9a2da02c56e93f5fc5f9399320f7f4dbac8d87eff9a539300d5740269eeda6be1302a2cf4a4b9c524780b286d9eb7898585fc530129a1f84341faf1e6fd0
diff --git a/net-misc/babeld/babeld-1.8.0.ebuild b/net-misc/babeld/babeld-1.9.1.ebuild
index c39edc852990..e0354998c9ec 100644
--- a/net-misc/babeld/babeld-1.8.0.ebuild
+++ b/net-misc/babeld/babeld-1.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -19,4 +19,5 @@ src_compile() {
src_install(){
emake "TARGET=${D}" PREFIX="${EPREFIX}"/usr install
dodoc CHANGES README
+ doinitd "${FILESDIR}"/${PN}
}
diff --git a/net-misc/babeld/files/babeld b/net-misc/babeld/files/babeld
index d45cf2d4e274..265d680e3997 100755..100644
--- a/net-misc/babeld/files/babeld
+++ b/net-misc/babeld/files/babeld
@@ -1,10 +1,10 @@
#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License, v2 or later
description="Babel routing daemon"
command=babeld
-pidfile=/var/run/$command.pid
+pidfile=/run/$command.pid
command_args="-I $pidfile -S /var/lib/babeld/state"
command_args_background="-D"
retry="TERM/30/KILL/5"