summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrome-remote-desktop/Manifest2
-rw-r--r--net-misc/chrome-remote-desktop/chrome-remote-desktop-49.0.2623.40.ebuild109
2 files changed, 0 insertions, 111 deletions
diff --git a/net-misc/chrome-remote-desktop/Manifest b/net-misc/chrome-remote-desktop/Manifest
index f8576cf434ab..c84053c0bfdb 100644
--- a/net-misc/chrome-remote-desktop/Manifest
+++ b/net-misc/chrome-remote-desktop/Manifest
@@ -1,3 +1 @@
-DIST chrome-remote-desktop_49.0.2623.40_amd64.deb 20315570 BLAKE2B 03725450590fad81105ae5314f9a1c9c9acc1b3f2d294ee1401379c264d59d737c2c39333ab5cb7a77e5885855ca484db360f0936be6c5bc2c84aa0cb38afe72 SHA512 d936885a986a749a0b4ebb1bb68fe0bc14d10d21363a409abbbb224b4f3ee048ef030ee81469be9bbb8c3852d7c6793fcab1f51d52fcaf5b02cda07550b72330
-DIST chrome-remote-desktop_49.0.2623.40_i386.deb 20941574 BLAKE2B 7f86e734fdc9c95f8820912aa075d4be805896f4f045ba39fb1fedc9ba6e3b576d71ce67692f683009ff005c2c248ed067ef4980906ae9e158c107aa96b58470 SHA512 00cf6641ee993fb8c295ca99cb57cde42eb3dd6cc34ae4684f858279615695d5b1a257081e8988293f94e887986492e112bc0276f572cd592d9879dec88eace8
DIST chrome-remote-desktop_63.0.3239.17_amd64.deb 19026074 BLAKE2B 9a62d317768d6c0ab3cf3c6e7c5dea074133cc7c5d2b04ffdc1e0f9877f5f606c044ebab7b230914eba2ade51d2805fb1267f7b1731fa36235495a8192eb3c48 SHA512 2843deb7817217c8b8e41931b1e9ef0fdfb40c6a4ceb1bc69499aed16cc729d7ed64f88200c9bb2366a768f294a164da2360ed2b9654d1626696bcf0403e347a
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-49.0.2623.40.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-49.0.2623.40.ebuild
deleted file mode 100644
index 36683aa535d6..000000000000
--- a/net-misc/chrome-remote-desktop/chrome-remote-desktop-49.0.2623.40.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
-# Fetch the Release file:
-# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
-# Which gives you the Packages file:
-# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
-# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
-# And finally gives you the file name:
-# pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
-#
-# Use curl to find the answer:
-# curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages | grep ^Filename
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit unpacker eutils python-single-r1
-
-DESCRIPTION="access remote computers via Chrome!"
-PLUGIN_URL="https://chrome.google.com/remotedesktop"
-HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
-BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
-SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )
- x86? ( ${BASE_URI}_i386.deb )"
-
-LICENSE="google-chrome"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# All the libs this package links against.
-RDEPEND="app-admin/sudo
- ${PYTHON_DEPS}
- >=dev-libs/expat-2
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- dev-python/psutil
- gnome-base/gconf:2
- media-libs/fontconfig
- media-libs/freetype:2
- sys-devel/gcc
- sys-libs/glibc
- sys-libs/pam
- x11-libs/cairo
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXtst
- x11-libs/pango"
-# Settings we just need at runtime.
-RDEPEND+="
- x11-base/xorg-server[xvfb]"
-DEPEND=""
-
-S=${WORKDIR}
-
-QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
- python_fix_shebang opt/google/chrome-remote-desktop/chrome-remote-desktop
-}
-
-src_install() {
- insinto /etc
- doins -r etc/opt
-
- insinto /opt
- doins -r opt/google
- chmod a+rx "${ED}"/opt/google/${PN}/* || die
-
- dodir /etc/pam.d
- dosym system-remote-login /etc/pam.d/${PN}
-
- dodoc usr/share/doc/${PN}/changelog*
-
- newinitd "${FILESDIR}"/${PN}.rc ${PN}
- newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "Two ways to launch the server:"
- elog "(1) access an existing desktop"
- elog " (a) install the Chrome plugin on the server & client:"
- elog " ${PLUGIN_URL}"
- elog " (b) on the server, run the Chrome plugin & enable remote access"
- elog " (c) on the client, connect to the server"
- elog "(2) headless system"
- elog " (a) install the Chrome plugin on the client:"
- elog " ${PLUGIN_URL}"
- elog " (b) visit https://accounts.google.com/o/oauth2/auth?response_type=code&scope=https://www.googleapis.com/auth/chromoting+https://www.googleapis.com/auth/googletalk+https://www.googleapis.com/auth/userinfo.email&access_type=offline&redirect_uri=https://chromoting-auth.googleplex.com/auth&approval_prompt=force&client_id=440925447803-avn2sj1kc099s0r7v62je5s339mu0am1.apps.googleusercontent.com&hl=en&from_login=1&as=-760f476eeaec11b8&pli=1&authuser=0"
- elog " (c) run the command mentioned on the server"
- elog " (d) on the client, connect to the server"
- elog
- elog "Configuration settings you might want to be aware of:"
- elog " ~/.${PN}-session - shell script to start your session"
- elog " /etc/init.d/${PN} - script to auto-restart server"
- fi
-}