summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/Manifest1
-rw-r--r--net-misc/wget/files/wget-1.19.2-fix-segfault-due-to-derefencing-null-ptr.patch66
-rw-r--r--net-misc/wget/files/wget-1.92.2-openssl-1.1.0-r1.patch80
-rw-r--r--net-misc/wget/wget-1.19.2-r2.ebuild114
4 files changed, 0 insertions, 261 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 3c58342fa163..5002301da687 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,4 +1,3 @@
DIST wget-1.19.1.tar.xz 2111756 BLAKE2B e5dcaa791f78bb2d7de19a6f689430cd692e1232b7392102936e5f3b4e3592861bcfc78e27df0c4b02a9002ce4c755e765a0a51749670464789fc9f07f8787f7 SHA512 00864d225439bcb7c5af01d7ef19efa615427812d3320ab3f4c8f62c38191e837b1392397843f935d7dc5860a4d0ce89ee31f2730c4a729402f1f2bf3e5f64e5
-DIST wget-1.19.2.tar.gz 4349267 BLAKE2B 3622d39ea477d4137bd7f2a443d141d8832e2e1adf4dceb5c396aea782fee31bd69ad2b49771062f25c57e6a21701f844077000dfa175e89eae26cf4c3fdca09 SHA512 a0f8afcc0767a8fd1acd64b1b1b27d177bc938e70cc3709c1b3faa6c1426ec926642cd8e49d292cec0268ee507683539b5152072110106de5a728a03efd8cedd
DIST wget-1.19.3.tar.gz 4311432 BLAKE2B 7c636465b1fe575531ec6616d27a07d3c4b398dda002eb4199d4c72906f233067a420f1c3a0878b3fe3cb9fae47a12cd50a83098f20f59ca6dd35bc37b1468a6 SHA512 8e1cbad2a31880befaf2c079bb17a357a135f6f2402048d27ac367430dbd932ef1b8197fb1002a64474e5480a8d9e41146b5cfd591d204b2f8b0bb240ecddb2c
DIST wget-1.19.4.tar.gz 4310657 BLAKE2B 3f2e5a32e897101761d449f079bf9df38e60b68284230553b03280a6262e60b3d0b5af3bd9fdd334d09cac5ed3417c3a7e8736b1710f3a7402a123b4633b95e4 SHA512 e84b0c40235b160ade69e18f2f139c782eb2387edc97a847c11dbb906c0273daf6d0ef5afe20360ba965c7da8b5e109f5a45e39ea93d20ec945575203235943a
diff --git a/net-misc/wget/files/wget-1.19.2-fix-segfault-due-to-derefencing-null-ptr.patch b/net-misc/wget/files/wget-1.19.2-fix-segfault-due-to-derefencing-null-ptr.patch
deleted file mode 100644
index 8a66e08c3e3b..000000000000
--- a/net-misc/wget/files/wget-1.19.2-fix-segfault-due-to-derefencing-null-ptr.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 973c26ed7d51052a7b6e120ed1b84e47266667e1 Mon Sep 17 00:00:00 2001
-From: Darshit Shah <darnir@gnu.org>
-Date: Mon, 6 Nov 2017 10:09:03 +0100
-Subject: Fix Segfault due to derefencing null ptr
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-* src/http.c(gethttp): When Encoding is gzip, ensure that the
-Content-Type Header was actually seen. Without this, the "type" variable
-is null causing a Segfault.
-
-Reported-By: Noël Köthe <noel@debian.org>
----
- src/http.c | 30 +++++++++++++++++++-----------
- 1 file changed, 19 insertions(+), 11 deletions(-)
-
-diff --git a/src/http.c b/src/http.c
-index 9954848..2a5454f 100644
---- a/src/http.c
-+++ b/src/http.c
-@@ -3714,22 +3714,30 @@ gethttp (const struct url *u, struct url *original_url, struct http_stat *hs,
- && opt.compression != compression_none)
- {
- /* Make sure the Content-Type is not gzip before decompressing */
-- const char * p = strchr (type, '/');
-- if (p == NULL)
-- {
-- hs->remote_encoding = ENC_GZIP;
-- hs->local_encoding = ENC_NONE;
-- }
-- else
-+ if (type)
- {
-- p++;
-- if (c_tolower(p[0]) == 'x' && p[1] == '-')
-- p += 2;
-- if (0 != c_strcasecmp (p, "gzip"))
-+ const char * p = strchr (type, '/');
-+ if (p == NULL)
- {
- hs->remote_encoding = ENC_GZIP;
- hs->local_encoding = ENC_NONE;
- }
-+ else
-+ {
-+ p++;
-+ if (c_tolower(p[0]) == 'x' && p[1] == '-')
-+ p += 2;
-+ if (0 != c_strcasecmp (p, "gzip"))
-+ {
-+ hs->remote_encoding = ENC_GZIP;
-+ hs->local_encoding = ENC_NONE;
-+ }
-+ }
-+ }
-+ else
-+ {
-+ hs->remote_encoding = ENC_GZIP;
-+ hs->local_encoding = ENC_NONE;
- }
- }
- #endif
---
-cgit v1.0-41-gc330
-
diff --git a/net-misc/wget/files/wget-1.92.2-openssl-1.1.0-r1.patch b/net-misc/wget/files/wget-1.92.2-openssl-1.1.0-r1.patch
deleted file mode 100644
index 79f33b157599..000000000000
--- a/net-misc/wget/files/wget-1.92.2-openssl-1.1.0-r1.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- a/src/openssl.c
-+++ b/src/openssl.c
-@@ -174,11 +174,16 @@ ssl_init (void)
- {
- SSL_METHOD const *meth;
- long ssl_options = 0;
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+ int ssl_proto_version = 0;
-+#endif
-
- #if OPENSSL_VERSION_NUMBER >= 0x00907000
- if (ssl_true_initialized == 0)
- {
-+#if OPENSSL_API_COMPAT < 0x10100000L
- OPENSSL_config (NULL);
-+#endif
- ssl_true_initialized = 1;
- }
- #endif
-@@ -202,8 +207,12 @@ ssl_init (void)
- CONF_modules_load_file(NULL, NULL,
- CONF_MFLAGS_DEFAULT_SECTION|CONF_MFLAGS_IGNORE_MISSING_FILE);
- #endif
-+#if OPENSSL_API_COMPAT >= 0x10100000L
-+ OPENSSL_init_ssl(0, NULL);
-+#else
- SSL_library_init ();
- SSL_load_error_strings ();
-+#endif
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
- SSLeay_add_all_algorithms ();
- SSLeay_add_ssl_algorithms ();
-@@ -229,16 +238,31 @@ ssl_init (void)
- ssl_options |= SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3;
- break;
- case secure_protocol_tlsv1:
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+ meth = TLS_client_method();
-+ ssl_proto_version = TLS1_VERSION;
-+#else
- meth = TLSv1_client_method ();
-+#endif
- break;
-
- #if OPENSSL_VERSION_NUMBER >= 0x10001000
- case secure_protocol_tlsv1_1:
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+ meth = TLS_client_method();
-+ ssl_proto_version = TLS1_1_VERSION;
-+#else
- meth = TLSv1_1_client_method ();
-+#endif
- break;
-
- case secure_protocol_tlsv1_2:
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >= 0x10100000L)
-+ meth = TLS_client_method();
-+ ssl_proto_version = TLS1_2_VERSION;
-+#else
- meth = TLSv1_2_client_method ();
-+#endif
- break;
- #else
- case secure_protocol_tlsv1_1:
-@@ -262,8 +286,15 @@ ssl_init (void)
- if (!ssl_ctx)
- goto error;
-
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >= 0x10100000L)
- if (ssl_options)
- SSL_CTX_set_options (ssl_ctx, ssl_options);
-+#endif
-+
-+#if !defined(LIBRESSL_VERSION_NUMBER) && (OPENSSL_VERSION_NUMBER >=0x10100000L)
-+ if (ssl_proto_version)
-+ SSL_CTX_set_min_proto_version(ssl_ctx, ssl_proto_version);
-+#endif
-
- /* OpenSSL ciphers: https://www.openssl.org/docs/apps/ciphers.html
- * Since we want a good protection, we also use HIGH (that excludes MD4 ciphers and some more)
diff --git a/net-misc/wget/wget-1.19.2-r2.ebuild b/net-misc/wget/wget-1.19.2-r2.ebuild
deleted file mode 100644
index b1bda330b2e4..000000000000
--- a/net-misc/wget/wget-1.19.2-r2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="https://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
-REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.19.2-fix-segfault-due-to-derefencing-null-ptr.patch
- "${FILESDIR}"/${PN}-1.92.2-openssl-1.1.0-r1.patch )
-
-# Force a newer libidn2 to avoid libunistring deps. #612498
-LIB_DEPEND="idn? ( >=net-dns/libidn2-0.14[static-libs(+)] )
- pcre? ( dev-libs/libpcre[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
- libressl? ( dev-libs/libressl[static-libs(+)] )
- )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
- nls? ( sys-devel/gettext )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # revert some hack that breaks linking, bug #585924
- if [[ ${CHOST} == *-darwin* ]] \
- || [[ ${CHOST} == *-solaris* ]] \
- || [[ ${CHOST} == *-uclibc* ]] \
- || [[ ${CHOST} == *-cygwin* ]] \
- ; then
- sed -i \
- -e 's/^ LIBICONV=$/:/' \
- configure || die
- fi
-}
-
-src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
-
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
-
- # There is no flag that controls this. libunistring-prefix only
- # controls the search path (which is why we turn it off below).
- # Further, libunistring is only needed w/older libidn2 installs,
- # and since we force the latest, we can force off libunistring. #612498
- ac_cv_libunistring=no \
- econf \
- --disable-assert \
- --disable-rpath \
- --without-included-libunistring \
- --without-libunistring-prefix \
- $(use_enable debug) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable pcre) \
- $(use_enable ssl digest) \
- $(use_enable ssl opie) \
- $(use_with idn libidn) \
- $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
- $(use_with uuid libuuid) \
- $(use_with zlib)
-}
-
-src_install() {
- default
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info \
- || die
-}