summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/yp-tools/Manifest1
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-nds/yp-tools/Manifest b/net-nds/yp-tools/Manifest
index 730b14b6cf9c..d6858d41f5a8 100644
--- a/net-nds/yp-tools/Manifest
+++ b/net-nds/yp-tools/Manifest
@@ -1 +1,2 @@
DIST yp-tools-4.2.2.tar.bz2 368673 BLAKE2B ddc0e6ff81042a632713afc201e8195f42346dd557e44770f8e0d48d2d510a5df1b51d9229912214cb6840a6cc97c6bbf8bbbfcac2eac5dbe06596a4fbd875be SHA512 e2856465e650823de87fcf0e7f18c4875b0540f271b3e564b3afe07d0df35dded7f09ecdf2494d099b31a15e098fc5e9065339f19df45c0489ca91a736c3eac9
+DIST yp-tools-4.2.3.tar.gz 195247 BLAKE2B 5e068f6856876dbf55c25030730195222fd331a06b8d57aa8a797a42c90538289a61ea8de1a2fee2d173e3444f76f82d111fc1120c287f90b7dbad1a2be23313 SHA512 2fcdaaeb8af4c3f62aa571a488c04561356681fc18b919ef728cfc1941578870cce74b136959f49e4ab04f988a79252163c1abe30b357788cb0b5faca7b5d147
diff --git a/net-nds/yp-tools/yp-tools-4.2.3.ebuild b/net-nds/yp-tools/yp-tools-4.2.3.ebuild
new file mode 100644
index 000000000000..25fa50172660
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="https://www.thkukuk.de/nis/"
+SRC_URI="https://github.com/thkukuk/yp-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="
+ net-libs/libtirpc:=
+ >=net-libs/libnsl-1.2.0:0="
+RDEPEND="${DEPEND}"
+# always uses libtirpc if present
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure () {
+ econf \
+ --disable-static \
+ --sysconfdir="${EPREFIX}"/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}"/domainname.service
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}