summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/files/sabnzbd14
-rwxr-xr-xnet-nntp/sabnzbd/files/sabnzbd.initd2
-rw-r--r--net-nntp/sabnzbd/sabnzbd-1.1.1.ebuild10
3 files changed, 5 insertions, 21 deletions
diff --git a/net-nntp/sabnzbd/files/sabnzbd b/net-nntp/sabnzbd/files/sabnzbd
deleted file mode 100644
index ccc1a67fcf71..000000000000
--- a/net-nntp/sabnzbd/files/sabnzbd
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-pyexe=python2.7
-
-if [ ! -x /usr/bin/${pyexe} ]; then
- pyexe=python2.6
-fi
-
-if [ ! -x /usr/bin/${pyexe} ]; then
- echo "No suitable python executable found in /usr/sbin (python2.6 || python2.7)"
- exit 1
-fi
-
-cd /usr/share/sabnzbd && /usr/bin/${pyexe} SABnzbd.py $*
diff --git a/net-nntp/sabnzbd/files/sabnzbd.initd b/net-nntp/sabnzbd/files/sabnzbd.initd
index ad11573f5498..a2a8407a48c4 100755
--- a/net-nntp/sabnzbd/files/sabnzbd.initd
+++ b/net-nntp/sabnzbd/files/sabnzbd.initd
@@ -24,7 +24,7 @@ start() {
--group ${SABNZBD_GROUP} \
--pidfile "${PIDFILE}" \
--wait 1000 \
- --exec /usr/bin/sabnzbd \
+ --exec /usr/share/sabnzbd/SABnzbd.py \
-- \
--config-file "${SABNZBD_CONFIGFILE}" \
--logging "${SABNZBD_LOGGING}" \
diff --git a/net-nntp/sabnzbd/sabnzbd-1.1.1.ebuild b/net-nntp/sabnzbd/sabnzbd-1.1.1.ebuild
index 120ac64ced80..d013e87a4798 100644
--- a/net-nntp/sabnzbd/sabnzbd-1.1.1.ebuild
+++ b/net-nntp/sabnzbd/sabnzbd-1.1.1.ebuild
@@ -79,17 +79,15 @@ src_prepare() {
src_install() {
local d
- dodir /usr/share/${PN}/sabnzbd
- insinto /usr/share/${PN}/
- doins SABnzbd.py
- fperms +x /usr/share/${PN}/SABnzbd.py
- dobin "${FILESDIR}"/sabnzbd
-
for d in cherrypy email icons interfaces locale po sabnzbd tools util; do
insinto /usr/share/${PN}/${d}
doins -r ${d}/*
done
+ insinto /usr/share/${PN}
+ insopts -m 0755
+ doins SABnzbd.py
+
python_optimize "${D}usr/share/${PN}"
newinitd "${FILESDIR}/${PN}.initd" "${PN}"