summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syrep/syrep-0.9.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-p2p/syrep/syrep-0.9.ebuild b/net-p2p/syrep/syrep-0.9.ebuild
index 5c015c5d59c5..d3656097df04 100644
--- a/net-p2p/syrep/syrep-0.9.ebuild
+++ b/net-p2p/syrep/syrep-0.9.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
inherit autotools
DESCRIPTION="A generic file repository synchronization tool"
@@ -18,6 +18,7 @@ DEPEND="sys-libs/zlib
doc? ( www-client/lynx )"
src_prepare() {
+ default
sed -i \
-e "s/#if (DB_VERSION_MAJOR != 4).*/#if (DB_VERSION_MAJOR < 4)/" \
configure.ac || die
@@ -33,8 +34,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- cd doc
- dodoc README *.txt
- use doc && dohtml *.html *.css
+ DOCS=( doc/README doc/*.txt )
+ use doc && HTML_DOCS=( doc/*.html doc/*.css )
+ default
}