summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/nutcracker/nutcracker-0.4.1.ebuild')
-rw-r--r--net-proxy/nutcracker/nutcracker-0.4.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-proxy/nutcracker/nutcracker-0.4.1.ebuild b/net-proxy/nutcracker/nutcracker-0.4.1.ebuild
new file mode 100644
index 000000000000..f97f42cfef33
--- /dev/null
+++ b/net-proxy/nutcracker/nutcracker-0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A fast, light-weight proxy for Memcached and Redis.
+(Twitter's Twemproxy)"
+HOMEPAGE="https://github.com/twitter/twemproxy"
+SRC_URI="https://github.com/twitter/twemproxy/archive/v0.4.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+DEPEND=">=dev-libs/libyaml-0.1.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/twemproxy-${PV}"
+
+src_prepare() {
+ # Lets use system libyaml
+ epatch "${FILESDIR}/${PN}-0.3.0-use-system-libyaml.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use debug) || die "Econf failed"
+}
+
+src_install() {
+ default_src_install
+
+ insinto /etc/nutcracker
+ newins conf/nutcracker.yml nutcracker.yml.example
+
+ newconfd "${FILESDIR}/nutcracker.confd" nutcracker
+ newinitd "${FILESDIR}/nutcracker.initd" nutcracker
+
+ if use doc; then
+ dodoc -r notes
+ fi
+}