summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/tayga')
-rw-r--r--net-proxy/tayga/files/tayga.confd2
-rw-r--r--net-proxy/tayga/files/tayga.initd20
-rw-r--r--net-proxy/tayga/tayga-0.9.2-r3.ebuild36
3 files changed, 58 insertions, 0 deletions
diff --git a/net-proxy/tayga/files/tayga.confd b/net-proxy/tayga/files/tayga.confd
new file mode 100644
index 000000000000..c601c33e58d3
--- /dev/null
+++ b/net-proxy/tayga/files/tayga.confd
@@ -0,0 +1,2 @@
+# Should match the tayga.conf tun-device
+#rc_need="net.nat64"
diff --git a/net-proxy/tayga/files/tayga.initd b/net-proxy/tayga/files/tayga.initd
new file mode 100644
index 000000000000..a0ad1dd30151
--- /dev/null
+++ b/net-proxy/tayga/files/tayga.initd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+#
+
+description='tayga NAT64 gateway'
+pidfile=${pidfile:=/var/run/tayga.pid}
+user=${user:=nobody}
+group=${group:=nogroup}
+datadir=${datadir:=/var/db/tayga}
+
+command='/usr/sbin/tayga'
+command_args="--pidfile ${pidfile} -u ${user} -g ${group}"
+
+start_pre() {
+ checkpath --directory --owner ${user}:${group} ${datadir}
+ checkpath --owner ${user}:${group} ${datadir}/dynamic.map
+}
+
+
diff --git a/net-proxy/tayga/tayga-0.9.2-r3.ebuild b/net-proxy/tayga/tayga-0.9.2-r3.ebuild
new file mode 100644
index 000000000000..4d84b05240f6
--- /dev/null
+++ b/net-proxy/tayga/tayga-0.9.2-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="out-of-kernel stateless NAT64 implementation based on TUN"
+HOMEPAGE="http://www.litech.org/tayga/"
+SRC_URI="http://www.litech.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-static-EAM.patch
+ "${FILESDIR}"/${P}-manpage-RFC.patch
+ "${FILESDIR}"/${P}-release-reserved-addr.patch
+)
+
+src_prepare() {
+ default
+ sed -e '/^CFLAGS/d' \
+ -i configure.ac || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tayga.confd
+ newinitd "${FILESDIR}"/tayga.initd
+}