summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/files/sshuttle-0.78.3-remote-python.patch70
-rw-r--r--net-proxy/sshuttle/sshuttle-0.78.3-r2.ebuild55
3 files changed, 0 insertions, 126 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index e40605347bd8..26c70d2d2da0 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1,2 +1 @@
-DIST sshuttle-0.78.3.tar.gz 69460 BLAKE2B af6835ac6ca8d2d4d94f86067b2d9024ad531de2c35f07432f4b7319c5ff133349c8975a15d30486bf5cc0e9d9a71798ec2d3ecab943b5992f66b5c371b45de1 SHA512 581955d9868bdd369a37386b273d53448944b1fb5458a25d5930b348630521cadcaea8cf45371942f96c789889d2a405e8bbe824af3d0c6def73f017f1149a1e
DIST sshuttle-0.78.4.tar.gz 72465 BLAKE2B 655df610757e245b66db61955306908c8d1e41db7d093dc44d55260a34b30d4605973815c64d59a860974e9a268e3fcefbba41a104da5ad73f6a8a292bc64b80 SHA512 6e3e49a638ad56fbb00b197d33426f9ccb9afe3d71f8109eb886bc9047083100c910fef7cb42f0426246e585138ce996872179d23fca98afd9e9ccca376da1e6
diff --git a/net-proxy/sshuttle/files/sshuttle-0.78.3-remote-python.patch b/net-proxy/sshuttle/files/sshuttle-0.78.3-remote-python.patch
deleted file mode 100644
index c8138f732771..000000000000
--- a/net-proxy/sshuttle/files/sshuttle-0.78.3-remote-python.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 9b7ce2811ec3ef35b9b7f7dfc157127bc46ece47 Mon Sep 17 00:00:00 2001
-From: vieira <vieira@yubo.be>
-Date: Fri, 20 Oct 2017 22:52:06 +0000
-Subject: [PATCH] Use versions of python3 greater than 3.5 when available (e.g.
- 3.6)
-
-Some Linux distros, like Alpine, Arch, etc and some BSDs, like FreeBSD, are
-now shipping with python3.6 as the default python3. Both the client and the
-server are failing to run in this distros, because we are specifically looking
-for python3.5.
-
-These changes make the run shell script use python3 if the version is greater
-than 3.5, otherwise falling back as usual.
-
-On the server any version of python3 will do, use it before falling back to
-python, as the server code can run with any version of python3.
----
- run | 28 +++++++++++++++++-----------
- sshuttle/ssh.py | 2 +-
- 2 files changed, 18 insertions(+), 12 deletions(-)
-
-diff --git a/run b/run
-index ec2d3f0..a14d831 100755
---- a/run
-+++ b/run
-@@ -1,11 +1,17 @@
--#!/bin/sh
--source_dir="$(dirname $0)"
--(cd "$source_dir" && "$source_dir/setup.py" --version > /dev/null)
--export PYTHONPATH="$source_dir:$PYTHONPATH"
--if python3.5 -V >/dev/null 2>&1; then
-- exec python3.5 -m "sshuttle" "$@"
--elif python2.7 -V >/dev/null 2>&1; then
-- exec python2.7 -m "sshuttle" "$@"
--else
-- exec python -m "sshuttle" "$@"
--fi
-+#!/usr/bin/env sh
-+set -e
-+export PYTHONPATH="$(dirname $0):$PYTHONPATH"
-+
-+python_best_version() {
-+ if [ -x "$(command -v python3)" ]; then
-+ if python3 -c "import sys; sys.exit(not sys.version_info > (3, 5))"; then
-+ exec python3 "$@"
-+ fi
-+ elif [ -x "$(command -v python2.7)" ]; then
-+ exec python2.7 "$@"
-+ else
-+ exec python "$@"
-+ fi
-+}
-+
-+python_best_version -m "sshuttle" "$@"
-diff --git a/sshuttle/ssh.py b/sshuttle/ssh.py
-index f4c84cc..a1f2997 100644
---- a/sshuttle/ssh.py
-+++ b/sshuttle/ssh.py
-@@ -116,7 +116,7 @@ def connect(ssh_cmd, rhostport, python, stderr, options):
- if python:
- pycmd = "'%s' -c '%s'" % (python, pyscript)
- else:
-- pycmd = ("P=python3.5; $P -V 2>/dev/null || P=python; "
-+ pycmd = ("P=python3; $P -V 2>/dev/null || P=python; "
- "exec \"$P\" -c %s") % quote(pyscript)
- pycmd = ("exec /bin/sh -c %s" % quote(pycmd))
- argv = (sshl +
---
-2.16.1
-
diff --git a/net-proxy/sshuttle/sshuttle-0.78.3-r2.ebuild b/net-proxy/sshuttle/sshuttle-0.78.3-r2.ebuild
deleted file mode 100644
index 1a4ce06c0fe5..000000000000
--- a/net-proxy/sshuttle/sshuttle-0.78.3-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit linux-info distutils-r1
-
-DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
-HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- net-firewall/iptables
-"
-DEPEND="
- dev-python/sphinx
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
-
-PATCHES=( "${FILESDIR}"/${P}-remote-python.patch )
-
-python_prepare_all() {
- # don't run tests via setup.py pytest
- sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C docs html man
-}
-
-python_test() {
- py.test || die "Tests fail under ${EPYTHON}"
-}
-
-python_install_all() {
- HTML_DOCS=( "${S}"/docs/_build/html/. )
- doman "${S}"/docs/_build/man/*
- distutils-r1_python_install_all
-}