summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/openmcu/files/openmcu.confd4
-rw-r--r--net-voip/openmcu/files/openmcu.rc64
-rw-r--r--net-voip/openmcu/openmcu-2.2.5-r1.ebuild75
3 files changed, 79 insertions, 4 deletions
diff --git a/net-voip/openmcu/files/openmcu.confd b/net-voip/openmcu/files/openmcu.confd
index ad54babfabce..4ec485757e78 100644
--- a/net-voip/openmcu/files/openmcu.confd
+++ b/net-voip/openmcu/files/openmcu.confd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#/etc/conf.d/openmcu.confd
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-voip/openmcu/files/openmcu.rc6 b/net-voip/openmcu/files/openmcu.rc6
index 444d5bbe793b..70f16736e43f 100644
--- a/net-voip/openmcu/files/openmcu.rc6
+++ b/net-voip/openmcu/files/openmcu.rc6
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-voip/openmcu/openmcu-2.2.5-r1.ebuild b/net-voip/openmcu/openmcu-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..458afbe26215
--- /dev/null
+++ b/net-voip/openmcu/openmcu-2.2.5-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user
+
+MY_PN=h323plus-app
+MY_PV=1_23_0
+DESCRIPTION="Simple Multi Conference Unit using H.323"
+HOMEPAGE="http://www.h323plus.org/"
+SRC_URI="mirror://sourceforge/h323plus/${MY_PN}-v${MY_PV}.tar.gz"
+
+LICENSE="MPL-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/ptlib:=
+ net-libs/h323plus:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/applications/${PN}
+
+src_prepare() {
+ # set path for various files
+ eapply "${FILESDIR}"/${PN}-2.2.1-path.patch
+
+ default
+}
+
+src_compile() {
+ emake OPENH323DIR=/usr/share/openh323
+}
+
+src_install() {
+ dosbin obj_*_*_*/${PN}
+
+ keepdir /usr/share/${PN}/data /usr/share/${PN}/html
+
+ # needed for daemon
+ keepdir /var/log/${PN} /var/run/${PN}
+
+ insinto /usr/share/${PN}/sounds
+ doins *.wav
+
+ insinto /etc/${PN}
+ doins server.pem
+ doins "${FILESDIR}"/${PN}.ini
+
+ doman ${PN}.1
+
+ dodoc ReadMe.txt
+
+ newinitd "${FILESDIR}"/${PN}.rc6 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_preinst() {
+ enewgroup openmcu
+ enewuser openmcu -1 -1 /dev/null openmcu
+}
+
+pkg_postinst() {
+ einfo "Setting permissions..."
+ chown -R openmcu:openmcu "${ROOT}"etc/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"etc/openmcu
+ chown -R openmcu:openmcu "${ROOT}"var/{log,run}/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"var/{log,run}/openmcu
+
+ echo
+ elog "This patched version of openmcu stores it's configuration"
+ elog "in \"/etc/openmcu/openmcu.ini\""
+}