summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/broadcom-sta/broadcom-sta-6.30.223.141-r1.ebuild')
-rw-r--r--net-wireless/broadcom-sta/broadcom-sta-6.30.223.141-r1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/net-wireless/broadcom-sta/broadcom-sta-6.30.223.141-r1.ebuild b/net-wireless/broadcom-sta/broadcom-sta-6.30.223.141-r1.ebuild
deleted file mode 100644
index 099e4ae716bb..000000000000
--- a/net-wireless/broadcom-sta/broadcom-sta-6.30.223.141-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-inherit eutils linux-info linux-mod
-
-DESCRIPTION="Broadcom's IEEE 802.11a/b/g/n hybrid Linux device driver"
-HOMEPAGE="http://www.broadcom.com/support/802.11/linux_sta.php"
-SRC_BASE="http://www.broadcom.com/docs/linux_sta/hybrid-v35"
-SRC_URI="x86? ( ${SRC_BASE}-nodebug-pcoem-${PV//\./_}.tar.gz )
- amd64? ( ${SRC_BASE}_64-nodebug-pcoem-${PV//\./_}.tar.gz )"
-
-LICENSE="Broadcom"
-KEYWORDS="~amd64 ~x86"
-
-RESTRICT="mirror"
-
-DEPEND="virtual/linux-sources"
-RDEPEND=""
-
-S="${WORKDIR}"
-
-MODULE_NAMES="wl(net/wireless)"
-MODULESD_WL_ALIASES=("wlan0 wl")
-
-pkg_setup() {
- # bug #300570
- # NOTE<lxnay>: module builds correctly anyway with b43 and SSB enabled
- # make checks non-fatal. The correct fix is blackisting ssb and, perhaps
- # b43 via udev rules. Moreover, previous fix broke binpkgs support.
- CONFIG_CHECK="~!B43 ~!SSB"
- CONFIG_CHECK2="LIB80211 ~!MAC80211 ~LIB80211_CRYPT_TKIP"
- ERROR_B43="B43: If you insist on building this, you must blacklist it!"
- ERROR_SSB="SSB: If you insist on building this, you must blacklist it!"
- ERROR_LIB80211="LIB80211: Please enable it. If you can't find it: enabling the driver for \"Intel PRO/Wireless 2100\" or \"Intel PRO/Wireless 2200BG\" (IPW2100 or IPW2200) should suffice."
- ERROR_MAC80211="MAC80211: If you insist on building this, you must blacklist it!"
- ERROR_PREEMPT_RCU="PREEMPT_RCU: Please do not set the Preemption Model to \"Preemptible Kernel\"; choose something else."
- ERROR_LIB80211_CRYPT_TKIP="LIB80211_CRYPT_TKIP: You will need this for WPA."
- if kernel_is ge 3 8 8; then
- CONFIG_CHECK="${CONFIG_CHECK} ${CONFIG_CHECK2} CFG80211 ~!PREEMPT_RCU ~!PREEMPT"
- elif kernel_is ge 2 6 32; then
- CONFIG_CHECK="${CONFIG_CHECK} ${CONFIG_CHECK2} CFG80211"
- elif kernel_is ge 2 6 31; then
- CONFIG_CHECK="${CONFIG_CHECK} ${CONFIG_CHECK2} WIRELESS_EXT ~!MAC80211"
- elif kernel_is ge 2 6 29; then
- CONFIG_CHECK="${CONFIG_CHECK} ${CONFIG_CHECK2} WIRELESS_EXT COMPAT_NET_DEV_OPS"
- else
- CONFIG_CHECK="${CONFIG_CHECK} IEEE80211 IEEE80211_CRYPT_TKIP"
- fi
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="-C ${KV_DIR} M=${S}"
- BUILD_TARGETS="wl.ko"
-}
-
-src_prepare() {
-# Makefile.patch: keep `emake install` working
-# linux-3.9.0.patch: add support for kernel 3.9.0
-# linux-3.10.0.patch: add support for kernel 3.10, bug #477372
- epatch "${FILESDIR}/${P}-makefile.patch" \
- "${FILESDIR}/${P}-linux-3.10.0.patch"
-
- epatch_user
-}