summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild
new file mode 100644
index 000000000000..c6033fd9cd9a
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="<net-wireless/gnuradio-3.7_rc:0=
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+}