summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild')
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild
deleted file mode 100644
index 1fd89429ed73..000000000000
--- a/net-wireless/kismet-ubertooth/kismet-ubertooth-2014.04.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit multilib
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
- inherit git-r3
- KEYWORDS=""
-else
- MY_PV=${PV/\./-}
- MY_PV=${MY_PV/./-R}
- S="${WORKDIR}/ubertooth-${MY_PV}"
- SRC_URI="https://github.com/greatscottgadgets/ubertooth/releases/download/${MY_PV}/ubertooth-${MY_PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="Provides basic bluetooth support in kismet"
-HOMEPAGE="http://ubertooth.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE=""
-
-DEPEND=">=net-wireless/kismet-2011.03.2-r1:= \
- >=net-wireless/ubertooth-2012.02.2:= \
- >=net-libs/libbtbb-2012.02.2:= \
- virtual/libusb:1"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- if has_version =net-wireless/kismet-9999; then
- cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
- else
- cd "${S}/host/kismet/plugin-ubertooth" || die
- fi
- emake KIS_SRC_DIR="/usr/include/kismet/"
-}
-
-src_install() {
- if has_version =net-wireless/kismet-9999; then
- cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
- else
- cd "${S}/host/kismet/plugin-ubertooth" || die
- fi
- emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
-}
-
-pkg_postinst() {
- ewarn "This package must be rebuilt every time kismet is rebuilt. Or else."
-}