summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/rfkill/rfkill-0.5.ebuild')
-rw-r--r--net-wireless/rfkill/rfkill-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-wireless/rfkill/rfkill-0.5.ebuild b/net-wireless/rfkill/rfkill-0.5.ebuild
new file mode 100644
index 000000000000..0c05937a4f77
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="http://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+CC=$(tc-getCC)
+LD=$(tc-getLD)
+
+src_compile() {
+ emake V=1 || die "Failed to compile"
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}" || die "Failed to install"
+}