summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapysdrplay/soapysdrplay-9999.ebuild')
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
index 935b6c269996..446b5336ed79 100644
--- a/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
+++ b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Soapy SDR plugin for SDRPlay"
-HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay3"
if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay3.git"
EGIT_CLONE_TYPE="shallow"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
+ COMMIT_HASH="b789d5985b900973c81c69aa04cb3c7ebe620a75"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay3-"${COMMIT_HASH}"
fi
LICENSE="Boost-1.0"
@@ -25,5 +26,5 @@ IUSE=""
REQUIRED_USE=""
RDEPEND="net-wireless/soapysdr
- net-wireless/sdrplay"
+ >=net-wireless/sdrplay-3.07"
DEPEND="${RDEPEND}"