summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/audio_common/audio_common-0.3.11.ebuild')
-rw-r--r--ros-meta/audio_common/audio_common-0.3.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/ros-meta/audio_common/audio_common-0.3.11.ebuild b/ros-meta/audio_common/audio_common-0.3.11.ebuild
new file mode 100644
index 000000000000..9eb443937326
--- /dev/null
+++ b/ros-meta/audio_common/audio_common-0.3.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common code for working with audio in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_capture
+ dev-ros/audio_common_msgs
+ dev-ros/audio_play
+"
+# dev-ros/sound_play
+# https://bugs.gentoo.org/612980#c14
+
+DEPEND="${RDEPEND}"