summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/image_pipeline')
-rw-r--r--ros-meta/image_pipeline/Manifest1
-rw-r--r--ros-meta/image_pipeline/image_pipeline-1.16.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/ros-meta/image_pipeline/Manifest b/ros-meta/image_pipeline/Manifest
index 4008f263090f..66299b03e6f1 100644
--- a/ros-meta/image_pipeline/Manifest
+++ b/ros-meta/image_pipeline/Manifest
@@ -1,2 +1,3 @@
DIST image_pipeline-1.15.2.tar.gz 147570 BLAKE2B 7e6ecad344e38426148017c4bdd109cdb505201256b811d7479b2fa5f2b6a94f94708ffd0e2a3c273f09fb8db0afdedb6955320bc142e4b48fbf94eeef45b453 SHA512 8fe9fa7759d83b2585589c6667c82b154c6ab748aa1644e8a58c75550e4c581fdea1b42f91a8c64df4eb7a06b33a76e55325268f314f3ec1f06ee38ee7b06bfc
DIST image_pipeline-1.15.3.tar.gz 150900 BLAKE2B 75bce8146c5273d5896ccb226bb9223f696f341089948aa44bbc932af15a1c80e6a5dbc036b4a37dcaecfca6a3e896df0935dcfb8305e23cc1a73fa77cef7a2e SHA512 9e1d21d1a43e932078938aeca4e5e6902e36e6d034a467cbd69734e318e5c4a689cb133acc7f8098f4ca928312661eb5b2aa7fae38e3d2a904b0e34889da0d32
+DIST image_pipeline-1.16.0.tar.gz 152681 BLAKE2B 6b11a07f07e8a29e601796570f404403d9acf1b31382d6d0353b2ac891c0f3345f3039bbb5bb7b3c41b10bf0478cad7a1d5590b7bbeee003aeff58437781d2e9 SHA512 909e115b150fb98a7cfa6d351b46072d92fccbded3ee15ba79135dae12d4cedf004b4c791a4c87540c74a6ad87e3947c9031e6539d09dee77527518d2b08cd18
diff --git a/ros-meta/image_pipeline/image_pipeline-1.16.0.ebuild b/ros-meta/image_pipeline/image_pipeline-1.16.0.ebuild
new file mode 100644
index 000000000000..2b6268fcea56
--- /dev/null
+++ b/ros-meta/image_pipeline/image_pipeline-1.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fills the gap between raw images from a camera and higher-level processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration
+ dev-ros/depth_image_proc
+ dev-ros/image_proc
+ dev-ros/image_publisher
+ dev-ros/image_rotate
+ dev-ros/image_view
+ dev-ros/stereo_image_proc
+"
+DEPEND="${RDEPEND}"