summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/robot/robot-9999.ebuild')
-rw-r--r--ros-meta/robot/robot-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/ros-meta/robot/robot-9999.ebuild b/ros-meta/robot/robot-9999.ebuild
new file mode 100644
index 000000000000..075d3ba57399
--- /dev/null
+++ b/ros-meta/robot/robot-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_base and includes ROS libaries for any robot hardware"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/ros_base
+ dev-ros/control_msgs
+ ros-meta/diagnostics
+ dev-ros/filters
+ ros-meta/geometry
+ ros-meta/robot_model
+ dev-ros/robot_state_publisher
+ dev-ros/xacro
+ ros-meta/executive_smach
+ dev-ros/actionlib
+ ros-meta/bond_core
+ dev-ros/class_loader
+ dev-ros/dynamic_reconfigure
+ ros-meta/common_tutorials
+ ros-meta/nodelet_core
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"