summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/embassy-structure')
-rw-r--r--sci-biology/embassy-structure/Manifest3
-rw-r--r--sci-biology/embassy-structure/embassy-structure-0.1.0-r3.ebuild13
-rw-r--r--sci-biology/embassy-structure/embassy-structure-0.1.650.ebuild15
-rw-r--r--sci-biology/embassy-structure/files/embassy-structure-0.1.650_fix-build-system.patch100
-rw-r--r--sci-biology/embassy-structure/metadata.xml5
5 files changed, 136 insertions, 0 deletions
diff --git a/sci-biology/embassy-structure/Manifest b/sci-biology/embassy-structure/Manifest
new file mode 100644
index 000000000000..7cd125ec2b29
--- /dev/null
+++ b/sci-biology/embassy-structure/Manifest
@@ -0,0 +1,3 @@
+DIST EMBOSS-6.0.1.tar.gz 20204153 SHA256 3e352902aa9dab88bf486457ff23794f19398dfc6b550c4bf175dfcad34c233d
+DIST embassy-6.0.1-structure-0.1.0.tar.gz 532035 SHA256 cd8b17947fe764e830bd14887deb85a5f196f490d25b9c6408aaca0c1baecd23
+DIST embassy-structure-0.1.650.tar.gz 588118 SHA256 06c3d07f495247d1427e91887fa00df053486e2b59f0ec722735bb0b957502f1 SHA512 56fb0ed975bfd95b1fbbccaf694e0617ec23971d53bdc230eeb6ca177907e784805697193e7630e4a513f1b4ee7a1a7974136520963557c452185be4ed22b641 WHIRLPOOL db988aab3f6d2165f44039385fd0a7ab2d6a7dce12906714d5932b411e3dfeac7e06a219af048ef120ea22acab3c1e958fefe68e6e1f19eec56de82c5c1b8c03
diff --git a/sci-biology/embassy-structure/embassy-structure-0.1.0-r3.ebuild b/sci-biology/embassy-structure/embassy-structure-0.1.0-r3.ebuild
new file mode 100644
index 000000000000..64b653083ff2
--- /dev/null
+++ b/sci-biology/embassy-structure/embassy-structure-0.1.0-r3.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EBOV="6.0.1"
+
+inherit embassy
+
+DESCRIPTION="Protein structure add-on package for EMBOSS"
+SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/old/${EBOV}/EMBOSS-${EBOV}.tar.gz
+ mirror://gentoo/embassy-${EBOV}-${PN:8}-${PV}.tar.gz"
+
+KEYWORDS="amd64 ~ppc x86"
diff --git a/sci-biology/embassy-structure/embassy-structure-0.1.650.ebuild b/sci-biology/embassy-structure/embassy-structure-0.1.650.ebuild
new file mode 100644
index 000000000000..b6fcd9770e3b
--- /dev/null
+++ b/sci-biology/embassy-structure/embassy-structure-0.1.650.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EBO_DESCRIPTION="Protein structure add-on package"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit emboss-r1
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}_fix-build-system.patch )
diff --git a/sci-biology/embassy-structure/files/embassy-structure-0.1.650_fix-build-system.patch b/sci-biology/embassy-structure/files/embassy-structure-0.1.650_fix-build-system.patch
new file mode 100644
index 000000000000..bdd9e37714e4
--- /dev/null
+++ b/sci-biology/embassy-structure/files/embassy-structure-0.1.650_fix-build-system.patch
@@ -0,0 +1,100 @@
+ configure.ac | 49 +++++++------------------------------------------
+ src/Makefile.am | 6 ++----
+ 2 files changed, 9 insertions(+), 46 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ee482ef..e4af4b1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd],
++ [],[PKG_CHECK_MODULES([PLPLOT], [plplot])]
++ )
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 81ade5d..2ed0d14 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -17,9 +17,7 @@ AM_CPPFLAGS = -I../../../nucleus -I../../../ajax/pcre \
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I${embprefix}/include -I${embprefix}/include/eplplot \
+- $(NLINCLUDES) \
+- -I${embprefix}/include/epcre
++AM_CPPFLAGS = -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -66,5 +64,5 @@ LDADD = ../../../nucleus/libnucleus.la ../../../ajax/acd/libacd.la \
+ $(XLIB)
+ else
+ LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lajax $(NLADD) $(XLIB)
+ endif
diff --git a/sci-biology/embassy-structure/metadata.xml b/sci-biology/embassy-structure/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/embassy-structure/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>