summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/njplot/njplot-2.3-r1.ebuild')
-rw-r--r--sci-biology/njplot/njplot-2.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/njplot/njplot-2.3-r1.ebuild b/sci-biology/njplot/njplot-2.3-r1.ebuild
new file mode 100644
index 000000000000..f766af55ea96
--- /dev/null
+++ b/sci-biology/njplot/njplot-2.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/njplot-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-biology/ncbi-tools[X,static-libs]
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s%njplot.help%${EPREFIX}/usr/share/doc/${PF}/njplot.help%" njplot-vib.c || die
+ epatch \
+ "${FILESDIR}"/${P}-format-security.patch \
+ "${FILESDIR}"/${P}-buildsystem.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin newicktops newicktotxt njplot unrooted
+ doman *.1
+ dodoc README njplot.help
+}