summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/samtools')
-rw-r--r--sci-biology/samtools/samtools-1.9-r1.ebuild (renamed from sci-biology/samtools/samtools-1.9.ebuild)19
1 files changed, 8 insertions, 11 deletions
diff --git a/sci-biology/samtools/samtools-1.9.ebuild b/sci-biology/samtools/samtools-1.9-r1.ebuild
index bdcd115aafee..0d0f993895fc 100644
--- a/sci-biology/samtools/samtools-1.9.ebuild
+++ b/sci-biology/samtools/samtools-1.9-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools python-single-r1 toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
HOMEPAGE="http://www.htslib.org/"
@@ -15,22 +13,18 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="examples"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
dev-lang/perl
=sci-libs/htslib-${PV}*
sys-libs/ncurses:0=
- sys-libs/zlib:=
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
- python_fix_shebang misc/varfilter.py
-
# remove bundled htslib
rm -r htslib-* || die
@@ -45,6 +39,9 @@ src_test() {
src_install() {
default
+ # varfilter.py has been retired upstream for being py2 only
+ rm "${ED}"/usr/bin/varfilter.py || die
+
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples