summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/tophat/tophat-2.0.8.ebuild')
-rw-r--r--sci-biology/tophat/tophat-2.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/tophat/tophat-2.0.8.ebuild b/sci-biology/tophat/tophat-2.0.8.ebuild
new file mode 100644
index 000000000000..c20007cd6160
--- /dev/null
+++ b/sci-biology/tophat/tophat-2.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/boost
+ sci-biology/samtools
+ sci-biology/seqan"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_prepare() {
+ rm -rf src/SeqAn* || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optim
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}