summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/pysam-0.12.0.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index c95db9a1dcd7..b01df416d508 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1 +1,2 @@
+DIST pysam-0.12.0.1.tar.gz 2672020 SHA256 04837bf0b1313e57d50076f228463262b9982c410b973eb184c033528f83d523 SHA512 31460ca98ad2ac5489905ffce76bfbb5bf4a295159f3cc8e088c78dcfbfc34b30d6f7871fd1454de01da98f82b7438ac2aca678a771d7b97ae0029a418f29f1d WHIRLPOOL 5bd9f29e7458cac3839aaa9703d4c5740b1268644947f31ce7d3ddd12e0ec1948611ca5228323ce9b3b8fa5a5e0623c6fa0a0e2ce7f197fdb81aa5465915af36
DIST pysam-0.12.tar.gz 2537142 SHA256 33922cb3277ed9a63457c1b6a9dcad2774a217ababcc97a854435be87ba80488 SHA512 095a47cd7258ef093a172445c425f382996da886e44e1beb81ecdec2325024e099d14bee6fcd928c4449099f51ad92b6d7ceb464815c463ab4478f162a40f21e WHIRLPOOL 2331e24d817cd3e7372df8e115498456e685ac426796b29c6d5a28edbaab2321f7efc9db0f14a000750fcd9e30391c02b81e439a07596813bdf7fc6c6e1a3ae3
diff --git a/sci-biology/pysam/pysam-0.12.0.1.ebuild b/sci-biology/pysam/pysam-0.12.0.1.ebuild
new file mode 100644
index 000000000000..1f4f58fdfe29
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.12.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.python.org/pypi/pysam"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.5*:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12-fix-buildsystem.patch )
+
+python_prepare_all() {
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${EPREFIX}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${EPREFIX}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ # prevent setup.py from adding RPATHs
+ sed -e "/ext\.extra_link_args += \['-Wl,-rpath,\$ORIGIN'\]/d" \
+ -i cy_build.py || die
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ # TODO
+ # empty compile, as the build system runs the whole build again in install
+ :
+}