summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/Manifest1
-rw-r--r--sci-biology/bowtie/bowtie-1.1.2.ebuild54
-rw-r--r--sci-biology/bowtie/bowtie-2.2.6.ebuild60
3 files changed, 0 insertions, 115 deletions
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index 77c558739950..824c7439adc1 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1,3 +1,2 @@
DIST bowtie-1.1.2-src.zip 7713258 BLAKE2B ac10aca905099b5a70d3fab6f90e2dc4713bf7b460d027abf89a6ef6103979724e70b2915a86ffa571b59dcd9df768c80be1846cccd08f7f85dd402ce64c0cb0 SHA512 3d3d69bc3a865bb577b5a91440215d0d5b606c7a8751d565e606e36adbfbdef695b1718ae81cd3e2682a39ca7784c4d00976441e7618264ad99b04c7f53c36e8
-DIST bowtie2-2.2.6-source.zip 5728779 BLAKE2B acd821376755e6bebfd58c39012a370b1aadf4cf8c52eafa1c648c93a0cab695c9c37761498260ed709bc25eb0b671797ff1c74da9787d616c8c39d1296a37eb SHA512 3ab5a5475cf214affd91e0d1782fd2d6dedccd979e3c809b5dfb272726d99ff1c7b59d92e387b187a7c2e43557786a1085186ccb96588de91212caf2eb94ce4f
DIST bowtie2-2.2.9-source.zip 5734235 BLAKE2B ec48e09fe05403d1085bb4e0c6ef1325b8912da0a8c942061c34f3381c6dd7ccdcc64c4bcdbb18c1da84ac57e1e34cc866fe79809c33c2769a8d75ecde7d0846 SHA512 ead8f7641f3231638d986f9e500bc4ec7afe1e542048465bfcc2e93e2b2d2e499f0dd8aa5c1e3e21df285c9d195b187682eb7e12be4a408f6c50fb97c0e0a205
diff --git a/sci-biology/bowtie/bowtie-1.1.2.ebuild b/sci-biology/bowtie/bowtie-1.1.2.ebuild
deleted file mode 100644
index 1ada8a0fdc2b..000000000000
--- a/sci-biology/bowtie/bowtie-1.1.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
-
-LICENSE="Artistic"
-SLOT="1"
-KEYWORDS="amd64 x86 ~x64-macos"
-
-IUSE="examples +tbb"
-
-DEPEND="app-arch/unzip
- tbb? ( dev-cpp/tbb )"
-RDEPEND=""
-
-DOCS=( AUTHORS NEWS TUTORIAL doc/README )
-HTML_DOCS=( doc/{manual.html,style.css} )
-
-src_prepare() {
- # always include tinythread.cpp
- epatch "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CFLAGS="" \
- CXXFLAGS="" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS}" \
- WITH_TBB="$(usex tbb 1 0)"
-}
-
-src_install() {
- dobin ${PN} ${PN}-*
-
- exeinto /usr/libexec/${PN}
- doexe scripts/*
-
- newman MANUAL ${PN}.1
- einstalldocs
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r genomes indexes
- fi
-}
diff --git a/sci-biology/bowtie/bowtie-2.2.6.ebuild b/sci-biology/bowtie/bowtie-2.2.6.ebuild
deleted file mode 100644
index 29826473a3b3..000000000000
--- a/sci-biology/bowtie/bowtie-2.2.6.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
-SRC_URI="mirror://sourceforge/project/${PN}-bio/${PN}2/${PV}/${PN}2-${PV}-source.zip"
-
-LICENSE="GPL-3"
-SLOT="2"
-KEYWORDS="amd64 x86"
-
-IUSE="examples cpu_flags_x86_sse2 +tbb"
-
-RDEPEND="dev-lang/perl"
-DEPEND="${RDEPEND}
- app-arch/unzip
- tbb? ( dev-cpp/tbb )"
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-DOCS=( AUTHORS NEWS TUTORIAL )
-HTML_DOCS=( doc/{manual.html,style.css} )
-
-pkg_pretend() {
- if ! use cpu_flags_x86_sse2 ; then
- eerror "This package requires a CPU supporting the SSE2 instruction set."
- die "SSE2 support missing"
- fi
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CXX="$(tc-getCXX)" \
- CFLAGS="" \
- CXXFLAGS="" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS} -msse2" \
- WITH_TBB="$(usex tbb 1 0)"
-}
-
-src_install() {
- dobin ${PN}2 ${PN}2-*
-
- exeinto /usr/libexec/${PN}2
- doexe scripts/*
-
- newman MANUAL ${PN}2.1
- einstalldocs
-
- if use examples; then
- insinto /usr/share/${PN}2
- doins -r example
- fi
-}