summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.5.ebuild45
-rw-r--r--sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch10
-rw-r--r--sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch24
-rw-r--r--sci-biology/bcftools/metadata.xml15
5 files changed, 95 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
new file mode 100644
index 000000000000..3540e9d20d54
--- /dev/null
+++ b/sci-biology/bcftools/Manifest
@@ -0,0 +1 @@
+DIST bcftools-1.5.tar.bz2 2975685 SHA256 9ff75a680891467776d7064f41deb6be7a595030ba807494727cd5bee7842301 SHA512 66b8bc61b9fbb381679a6781f77a18f66e8105567992da011413bc573d99b619558a1cf58e9e1373ae347a8b81638dd91977802a07a4578ddc9c61fb53403233 WHIRLPOOL 86b827d91351d8adc026a1d851bb708e35febcc36a947532662857787ec1da6eea2c88a684b15164638b7f9235f6a6f92f4d10618e1719aa891c44c69aaece77
diff --git a/sci-biology/bcftools/bcftools-1.5.ebuild b/sci-biology/bcftools/bcftools-1.5.ebuild
new file mode 100644
index 000000000000..9b5df1130999
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5-buildsystem.patch
+ "${FILESDIR}"/${PN}-1.5-fix-shebangs.patch
+)
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --disable-configure-htslib \
+ --with-htslib=system
+}
diff --git a/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch b/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch
new file mode 100644
index 000000000000..304fc03e7441
--- /dev/null
+++ b/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -275,7 +275,6 @@
+ $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_SCRIPT) $(MISC_SCRIPTS) $(DESTDIR)$(misc_bindir)
+ $(INSTALL_MAN) doc/bcftools.1 $(DESTDIR)$(man1dir)
+- $(INSTALL_PROGRAM) plugins/*.so $(DESTDIR)$(plugindir)
+
+ clean: testclean clean-plugins
+ -rm -f gmon.out *.o *~ $(PROG) version.h plugins/*.so plugins/*.P
diff --git a/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch b/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch
new file mode 100644
index 000000000000..c6cfc8b991d3
--- /dev/null
+++ b/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch
@@ -0,0 +1,24 @@
+--- a/misc/guess-ploidy.py
++++ b/misc/guess-ploidy.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2.7
+ #
+ # Plot the output of "bcftools +guess-ploidy -v"
+ #
+--- a/misc/plot-roh.py
++++ b/misc/plot-roh.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2.7
+
+ import glob, gzip, csv, sys, os, copy, re
+ csv.register_dialect('tab', delimiter='\t', quoting=csv.QUOTE_NONE)
+--- a/misc/vcfutils.pl
++++ b/misc/vcfutils.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl
+ #
+ # Copyright (C) 2010 Broad Institute.
+ # Copyright (C) 2011, 2014 Genome Research Ltd.
diff --git a/sci-biology/bcftools/metadata.xml b/sci-biology/bcftools/metadata.xml
new file mode 100644
index 000000000000..4fd13be2f922
--- /dev/null
+++ b/sci-biology/bcftools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samtools/bcftools</remote-id>
+ </upstream>
+</pkgmetadata>