summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-fix-build-system.patch135
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-ldflags.patch15
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch31
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch16
-rw-r--r--sci-biology/infernal/infernal-1.0.2-r1.ebuild13
5 files changed, 142 insertions, 68 deletions
diff --git a/sci-biology/infernal/files/infernal-1.0.2-fix-build-system.patch b/sci-biology/infernal/files/infernal-1.0.2-fix-build-system.patch
new file mode 100644
index 000000000000..41ab3103594b
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-fix-build-system.patch
@@ -0,0 +1,135 @@
+* Fix parallel build
+* Respect AR
+* Respect DESTDIR
+* Respect LDFLAGS
+
+--- a/easel/Makefile.in
++++ b/easel/Makefile.in
+@@ -17,7 +17,6 @@
+ #
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+-AR = @AR@ rcv
+ LN = ln
+ RANLIB = @RANLIB@
+ LDFLAGS = -static @LDFLAGS@
+@@ -132,13 +131,13 @@
+ esl_wuss.o
+
+ all: libeasel.a
+- (cd miniapps; make)
++ $(MAKE) -C miniapps
+
+ .c.o:
+ ${CC} -I. ${CFLAGS} ${SIMDFLAGS} ${DEFS} -c $<
+
+ libeasel.a: $(OBJS)
+- $(AR) libeasel.a $(OBJS)
++ $(AR) rcv libeasel.a $(OBJS)
+ $(RANLIB) libeasel.a
+ chmod 644 libeasel.a
+
+--- a/easel/testsuite/Makefile.in
++++ b/easel/testsuite/Makefile.in
+@@ -15,7 +15,6 @@
+ LIBS = @LIBGSL@ @LIBS@ -lm
+ MPILIBS = @MPILIBS@
+
+-AR = @AR@ rcv
+ RANLIB = @RANLIB@
+
+ ESLDIR = ..
+--- a/iinfernal-1/Makefile.in
++++ b/iinfernal-1/Makefile.in
+@@ -20,7 +20,6 @@
+ # only used for building the testsuite anyway... e.g. we
+ # make a "libhmmer.a" library for building the testsuite.
+ #
+-AR = @AR@ rcv
+ RANLIB = @RANLIB@
+
+ MPILIBS = @MPILIBS@
+@@ -63,7 +62,7 @@
+ module: libinfernal.a
+
+ libinfernal.a: $(OBJS)
+- $(AR) libinfernal.a $(OBJS)
++ $(AR) rcv libinfernal.a $(OBJS)
+ $(RANLIB) libinfernal.a
+ chmod 644 libinfernal.a
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,9 +82,10 @@
+ all: core
+
+ core:
+- (cd easel; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make)
+- (cd src; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make module)
+- (cd testsuite; make CC="$(CC)" CFLAGS="$(CFLAGS)")
++ $(MAKE) -C easel
++ $(MAKE) -C src
++ $(MAKE) -C src module
++ $(MAKE) -C testsuite
+
+ #.PHONY: $(RIGFILTERS)
+ #$(RIGFILTERS): core
+@@ -202,9 +203,9 @@
+ # "make install" installs the programs in BINDIR
+ #
+ install:
+- mkdir -p ${BINDIR}
++ mkdir -p $(DESTDIR)${BINDIR}
+ for file in $(PROGS); do\
+- cp src/$$file $(BINDIR)/;\
++ cp src/$$file $(DESTDIR)$(BINDIR)/;\
+ done
+ # if test -d $(RIGFILTERS); then\
+ # for file in $(RFPROGS); do\
+--- a/rigfilters/cfsqp/Makefile.in
++++ b/rigfilters/cfsqp/Makefile.in
+@@ -24,7 +24,6 @@
+ ## archiving command, and ranlib command.
+ # these are used to create the libcfsqp.a library, necessary for cm2hmm
+ #
+-AR = @AR@ rcv
+ RANLIB = @RANLIB@
+
+ OBJS = cfsqp.o\
+@@ -41,7 +40,7 @@
+ all: libcfsqp.a
+
+ libcfsqp.a: $(OBJS) ${HDRS}
+- $(AR) libcfsqp.a $(OBJS)
++ $(AR) rcv libcfsqp.a $(OBJS)
+ $(RANLIB) libcfsqp.a
+ chmod 644 libcfsqp.a
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -27,7 +27,6 @@
+ # only used for building the testsuite anyway... e.g. we
+ # make a "libinfernal.a" library for building the testsuite.
+ #
+-AR = @AR@ rcv
+ RANLIB = @RANLIB@
+
+ # configuration for optional MPI functionality
+@@ -86,7 +85,7 @@
+ all: $(PROGS)
+
+ $(PROGS): @EXEC_DEPENDENCY@ $(OBJS) ${HDRS}
+- $(CC) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
+
+
+ #################################################################
+@@ -95,7 +94,7 @@
+ module: libinfernal.a
+
+ libinfernal.a: $(OBJS) ${HDRS}
+- $(AR) libinfernal.a $(OBJS)
++ $(AR) rcv libinfernal.a $(OBJS)
+ $(RANLIB) libinfernal.a
+ chmod 644 libinfernal.a
+
diff --git a/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch b/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
deleted file mode 100644
index f688dce152ed..000000000000
--- a/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Respect LDFLAGS
-
-http://bugs.gentoo.org/show_bug.cgi?id=338177
-
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -86,7 +86,7 @@
- all: $(PROGS)
-
- $(PROGS): @EXEC_DEPENDENCY@ $(OBJS) ${HDRS}
-- $(CC) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
-
-
- #################################################################
diff --git a/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
deleted file mode 100644
index 67ffa6fda7f6..000000000000
--- a/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix parallel build
-
-http://bugs.gentoo.org/show_bug.cgi?id=311919
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -82,9 +82,10 @@
- all: core
-
- core:
-- (cd easel; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make)
-- (cd src; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make module)
-- (cd testsuite; make CC="$(CC)" CFLAGS="$(CFLAGS)")
-+ $(MAKE) -C easel
-+ $(MAKE) -C src
-+ $(MAKE) -C src module
-+ $(MAKE) -C testsuite
-
- #.PHONY: $(RIGFILTERS)
- #$(RIGFILTERS): core
---- a/easel/Makefile.in
-+++ b/easel/Makefile.in
-@@ -132,7 +132,7 @@
- esl_wuss.o
-
- all: libeasel.a
-- (cd miniapps; make)
-+ $(MAKE) -C miniapps
-
- .c.o:
- ${CC} -I. ${CFLAGS} ${SIMDFLAGS} ${DEFS} -c $<
diff --git a/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch b/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
deleted file mode 100644
index ea465e592ffa..000000000000
--- a/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Build system does not respect DESTDIR by default.
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -203,9 +203,9 @@
- # "make install" installs the programs in BINDIR
- #
- install:
-- mkdir -p ${BINDIR}
-+ mkdir -p $(DESTDIR)${BINDIR}
- for file in $(PROGS); do\
-- cp src/$$file $(BINDIR)/;\
-+ cp src/$$file $(DESTDIR)$(BINDIR)/;\
- done
- # if test -d $(RIGFILTERS); then\
- # for file in $(RFPROGS); do\
diff --git a/sci-biology/infernal/infernal-1.0.2-r1.ebuild b/sci-biology/infernal/infernal-1.0.2-r1.ebuild
index e906c23024ff..2e96418b6bb9 100644
--- a/sci-biology/infernal/infernal-1.0.2-r1.ebuild
+++ b/sci-biology/infernal/infernal-1.0.2-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Inference of RNA alignments"
HOMEPAGE="http://infernal.janelia.org/"
@@ -9,21 +11,20 @@ SRC_URI="ftp://selab.janelia.org/pub/software/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-IUSE="mpi"
KEYWORDS="amd64 x86"
+IUSE="mpi"
RDEPEND="mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${P}-parallel-build.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
"${FILESDIR}"/${P}-overflows.patch
"${FILESDIR}"/${P}-perl-5.16-2.patch
- "${FILESDIR}"/${P}-ldflags.patch
- "${FILESDIR}"/${P}-respect-DESTDIR.patch
)
src_configure() {
+ tc-export AR
econf $(use_enable mpi)
}