summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/calcoo')
-rw-r--r--sci-calculators/calcoo/Manifest1
-rw-r--r--sci-calculators/calcoo/calcoo-1.3.18.ebuild35
-rw-r--r--sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch16
-rw-r--r--sci-calculators/calcoo/metadata.xml12
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-calculators/calcoo/Manifest b/sci-calculators/calcoo/Manifest
new file mode 100644
index 000000000000..3365c91f9a16
--- /dev/null
+++ b/sci-calculators/calcoo/Manifest
@@ -0,0 +1 @@
+DIST calcoo-1.3.18.tar.gz 133605 SHA256 7daa6f089922e6a65812d20374803335af4272a2716a4c148747b5620b2aa069 SHA512 e03fd61abb1e5500a1e4eb91e732ced1c963770ddb85824430511cc5c14d1f5af1095e2fdc7b8b483afba94e3ac8381a001e0a42dccaa182c1a888e90afd14a7 WHIRLPOOL 027091bb65af9d9da7ecedbe861abcdcc04bdb7e16dc132e9e0b87d5d52b3b5513e00a631cc34c2b6a4a7320619661374719863f0e02965e08bb928da7ec5ba7
diff --git a/sci-calculators/calcoo/calcoo-1.3.18.ebuild b/sci-calculators/calcoo/calcoo-1.3.18.ebuild
new file mode 100644
index 000000000000..f1f855c434a8
--- /dev/null
+++ b/sci-calculators/calcoo/calcoo-1.3.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Scientific calculator designed to provide maximum usability"
+HOMEPAGE="http://calcoo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gold.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-gtktest )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newicon src/pixmaps/main.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Calcoo ${PN} "Education;Math"
+}
diff --git a/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch b/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch
new file mode 100644
index 000000000000..1369dd526b28
--- /dev/null
+++ b/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch
@@ -0,0 +1,16 @@
+ src/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b14dc1e..d713b51 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -36,7 +36,7 @@ output.c \
+ texts.h
+
+ INCLUDES = @GTK_CFLAGS@
+-LDADD = @GTK_LIBS@
++LDADD = @GTK_LIBS@ -lm
+ CLEANFILES = *~
+ DISTCLEANFILES = .deps/*.P
+
diff --git a/sci-calculators/calcoo/metadata.xml b/sci-calculators/calcoo/metadata.xml
new file mode 100644
index 000000000000..c5a8a0875d1a
--- /dev/null
+++ b/sci-calculators/calcoo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Calcoo is a scientific calculator designed to provide maximum
+ usability.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">calcoo</remote-id>
+ </upstream>
+</pkgmetadata>