summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/gonvert/Manifest1
-rw-r--r--sci-calculators/gonvert/gonvert-0.2.39.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-calculators/gonvert/Manifest b/sci-calculators/gonvert/Manifest
index effe02868b36..e195d661e54c 100644
--- a/sci-calculators/gonvert/Manifest
+++ b/sci-calculators/gonvert/Manifest
@@ -1,2 +1,3 @@
DIST gonvert-0.2.25.tar.gz 123384 SHA256 025e2de285cefaf398b62eb83b2db2e9b2e6e3e4e36615b949c8e596b5e39678 SHA512 7f8fe235afde30394b5abd6b19abeb7282be84e98c4966d260f6542239dbc18c48dcf0e852cd5e077cccc6ecca1582af5cecc46560a4119e461005a438575b90 WHIRLPOOL 0391514dc322e52a55963219da90418ad571a361e3a4485ebb83a0f1ca9f6d4296361c2b412f687cd9a17e4bd994ccbcd9ad12ed64bb0bb2bafd17a9215bb0ee
DIST gonvert-0.2.32.tar.gz 124613 SHA256 9b4b2b7df01038e5edaee6b45990b4344689cd1c378e207cb2980537b1d12e61 SHA512 82fe2da15808c5efcfff983ad12f82563b4106279a1c07a05c67a4b7cb899569edfda396fceb0e6f3d69c4dca4680719db2cc7842600f0715ced4c6235e233b9 WHIRLPOOL ff845e96f468357cd0ce086ac34106da50c736945748ed49840e439b4a3030124d6993d5077f257cafb03662201e3b622a59dd3f86820062132f55a07f87fd9c
+DIST gonvert-0.2.39.tar.gz 125040 SHA256 013b5b8be7d4af05667bc3689bda021e843e5bb8362d72727076ab77df375de1 SHA512 508c4fe4a453f68ea48787843b96b7f6ee6706e7a264c5698ceb5cba3b90996f506e67230d37b2750db69921aba90f56d4eca2a21531c33aa5cdd95e2ca9ea4b WHIRLPOOL de1667b98d9edaf0ee2119333bcd96b51ec510ed76ede277124d98f7179e7ac863063d0fc834209ea25ef3f6a399a40c7ab334b1ed7a8160e0d7f260165b2c3b
diff --git a/sci-calculators/gonvert/gonvert-0.2.39.ebuild b/sci-calculators/gonvert/gonvert-0.2.39.ebuild
new file mode 100644
index 000000000000..e8eb5a74ff53
--- /dev/null
+++ b/sci-calculators/gonvert/gonvert-0.2.39.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Unit conversion utility written in PyGTK"
+HOMEPAGE="http://unihedron.com/projects/gonvert/index.php"
+SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygtk:2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.2.23-paths.patch )
+
+src_install () {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr"
+ python_fix_shebang "${ED%/}"/usr/bin
+ rm -fr "${ED%/}/usr/share/doc/${PN}" || die
+ einstalldocs
+}