summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/files/ffmpeg29.patch22
-rw-r--r--sci-electronics/gazebo/gazebo-5.1.0.ebuild5
2 files changed, 26 insertions, 1 deletions
diff --git a/sci-electronics/gazebo/files/ffmpeg29.patch b/sci-electronics/gazebo/files/ffmpeg29.patch
new file mode 100644
index 000000000000..df53cc7f1e9c
--- /dev/null
+++ b/sci-electronics/gazebo/files/ffmpeg29.patch
@@ -0,0 +1,22 @@
+Index: gazebo5_5.1.0/gazebo/common/Video.cc
+===================================================================
+--- gazebo5_5.1.0.orig/gazebo/common/Video.cc
++++ gazebo5_5.1.0/gazebo/common/Video.cc
+@@ -147,7 +147,7 @@ bool Video::Load(const std::string &_fil
+ return false;
+ }
+
+- avpicture_alloc(this->pic, PIX_FMT_RGB24, this->codecCtx->width,
++ avpicture_alloc(this->pic, AV_PIX_FMT_RGB24, this->codecCtx->width,
+ this->codecCtx->height);
+
+ this->swsCtx = sws_getContext(
+@@ -156,7 +156,7 @@ bool Video::Load(const std::string &_fil
+ this->codecCtx->pix_fmt,
+ this->codecCtx->width,
+ this->codecCtx->height,
+- PIX_FMT_RGB24,
++ AV_PIX_FMT_RGB24,
+ SWS_BICUBIC, NULL, NULL, NULL);
+
+ if (this->swsCtx == NULL)
diff --git a/sci-electronics/gazebo/gazebo-5.1.0.ebuild b/sci-electronics/gazebo/gazebo-5.1.0.ebuild
index d1a55a1ed8ff..81d360d79cb8 100644
--- a/sci-electronics/gazebo/gazebo-5.1.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-5.1.0.ebuild
@@ -45,7 +45,10 @@ DEPEND="${RDEPEND}
"
S="${WORKDIR}/${PN}$(get_major_version)_${PV}"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=( "${FILESDIR}/bullet_283.patch" )
+PATCHES=(
+ "${FILESDIR}/bullet_283.patch"
+ "${FILESDIR}/ffmpeg29.patch"
+)
src_configure() {
# doesnt build without it