summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/kicad/kicad-9999.ebuild')
-rw-r--r--sci-electronics/kicad/kicad-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-electronics/kicad/kicad-9999.ebuild b/sci-electronics/kicad/kicad-9999.ebuild
index 2105a3f3d54..f7c3c3e7254 100644
--- a/sci-electronics/kicad/kicad-9999.ebuild
+++ b/sci-electronics/kicad/kicad-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
WX_GTK_VER="3.0-gtk3"
inherit check-reqs cmake optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
@@ -37,7 +37,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Depend on opencascade:0 to get unslotted variant (so we know path to it), bug #833301
COMMON_DEPEND="
!sci-electronics/kicad-i18n
- >=dev-libs/boost-1.61:=[context,nls]
+ dev-libs/boost:=[context,nls]
media-libs/freeglut
media-libs/glew:0=
>=media-libs/glm-0.9.9.1
@@ -46,7 +46,7 @@ COMMON_DEPEND="
>=x11-libs/pixman-0.30
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
$(python_gen_cond_dep '
- >=dev-libs/boost-1.61:=[context,nls,python,${PYTHON_USEDEP}]
+ dev-libs/boost:=[context,nls,python,${PYTHON_USEDEP}]
dev-python/wxpython:4.0[${PYTHON_USEDEP}]
')
${PYTHON_DEPS}