summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/quartus-prime-lite/Manifest1
-rw-r--r--sci-electronics/quartus-prime-lite/metadata.xml8
-rw-r--r--sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild49
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-electronics/quartus-prime-lite/Manifest b/sci-electronics/quartus-prime-lite/Manifest
new file mode 100644
index 000000000000..ea5a4733086e
--- /dev/null
+++ b/sci-electronics/quartus-prime-lite/Manifest
@@ -0,0 +1 @@
+DIST Quartus-lite-15.1.0.185-linux.tar 5969776640 SHA256 fd670ee4caee69e9533b7a826af1040bc0e35ef68ca1b43e73d8b69cbf14c7f4 SHA512 7996bc9e0561b650c0318d608b4f59560dd631e3a38c403105f797049c395ce25a0ff5d4346cf6e91338fa297d7e8752ef5a3f83f496d4431ad3591de4335045 WHIRLPOOL 1549939fc9e7ce94b9b2c3032db78ff66ca1f4542831fe15fadb83ba0efab4305430924ed0ac3d47288f7ae85c4b75818c87a5399a6868adcee606e20388d894
diff --git a/sci-electronics/quartus-prime-lite/metadata.xml b/sci-electronics/quartus-prime-lite/metadata.xml
new file mode 100644
index 000000000000..42ed446b917c
--- /dev/null
+++ b/sci-electronics/quartus-prime-lite/metadata.xml
@@ -0,0 +1,8 @@
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan Horan</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild b/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild
new file mode 100644
index 000000000000..395c34ee4215
--- /dev/null
+++ b/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Full-featured EDA product for altera devices"
+HOMEPAGE="https://www.altera.com/products/design-software/fpga-design/quartus-prime/overview.html"
+SRC_URI="Quartus-lite-${PV}-linux.tar"
+# variable to store the download URL
+DOWNLOADPAGE="http://dl.altera.com/?edition=lite"
+
+LICENSE="Quartus-prime-megacore"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libpng:1.2"
+
+RESTRICT="fetch bindist"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ elog "Due to licensing restrictions, you need to download the distfile manually."
+ elog "Please navigate to ${DOWNLOADPAGE}"
+ elog "Sign in with your Altera account (you need to register)"
+ elog "Download ${SRC_URI} and place it into ${DISTDIR}"
+ elog "And restart the installation."
+}
+
+pkg_pretend() {
+ einfo "The checksum and unpack will take quite some time to run"
+}
+
+src_install() {
+ einfo "The Quartus install runs in unattended mode"
+ einfo "you wont see much and it will take a long time"
+
+ ./setup.sh --mode unattended --unattendedmodeui none \
+ --installdir "${D}/opt/quartus-lite-${PV}"
+ make_desktop_entry "/opt/quartus-lite-${PV}/quartus/bin/quartus" \
+ "Quartus lite ${PV}" "/opt/quartus-lite-${PV}/quartus/adm/quartusii.png"
+}
+
+pkg_postinst() {
+ elog "To launch Quartus, run /opt/quartus-lite-${PV}/quartus/bin/quartus"
+}