summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ngspice/Manifest2
-rw-r--r--sci-electronics/ngspice/files/ngspice-26-respect-ldflags.patch31
-rw-r--r--sci-electronics/ngspice/ngspice-26.ebuild102
3 files changed, 0 insertions, 135 deletions
diff --git a/sci-electronics/ngspice/Manifest b/sci-electronics/ngspice/Manifest
index 15963ee80df1..106266fe01b9 100644
--- a/sci-electronics/ngspice/Manifest
+++ b/sci-electronics/ngspice/Manifest
@@ -1,4 +1,2 @@
-DIST ngspice-26-manual.pdf 2141771 BLAKE2B 16956c46640de4696f7197997b170a2b1aad9b2f9fbe299b801de100d8aaca949b5be6f259e353a168ae90d992d91ff65e8a819b49fdf509fae98ec7dfa610d7 SHA512 1c160aeef61d8091a6d788677bcf7ea682393cc886d5d535f87bb800cdae4f095cbf1e833babadea481956b904b4bdb688cc18b80d9d6a29cab33a54275abab1
-DIST ngspice-26.tar.gz 6925987 BLAKE2B 8f8e54000234ea3896a55863df99b6ce83ad322e3049845e0a817635ebfebdc8398e6fa4831727c4798a8d9dce1b1c2a01354505e48dc0b2db9e9036aa2ae5aa SHA512 eb6a81df90de803c9f7544e8d0de7cc413aac169f69d1dec5cc6d2e667b66d42aede7f14c75bcdd10288be0c2ac07863fd4028b9fe59f2f515d680c2ffa41cab
DIST ngspice-27-manual.pdf 3117788 BLAKE2B 6e271abc50b0139c4776844ea31176d231e68c70ce34d0daec48aefc5ef5a9eac90a77f3141081f38c6ac8d42bb95ec061bf1d43bfd3a4fb13e4822c2eff4f57 SHA512 ed87764715917e2cd832c49e911a2908dba9907f9f01c933cb7f97a92c7f9ff345bc26a2f0561dd34b2eede6874b6a67b4864abf3dcff127bd0306e778e997b5
DIST ngspice-27.tar.gz 7372998 BLAKE2B ce8590518fa4eb4292c73c4eaefdd9d0da19bca8120b51daae954a5b9d86f51912d2dccb5a827480caadce8321373d96f045226db4986a78bcc9170f2e46f9a5 SHA512 1714f95ab5716c228a0b39395a742e8b9a823e0e6f7e08625d089541ea786df5fd7b9d2982bcec8431e27ac6ba7603ecc507f9cfcb0a6aacd53f5633f52bd2ea
diff --git a/sci-electronics/ngspice/files/ngspice-26-respect-ldflags.patch b/sci-electronics/ngspice/files/ngspice-26-respect-ldflags.patch
deleted file mode 100644
index 31fe300b105f..000000000000
--- a/sci-electronics/ngspice/files/ngspice-26-respect-ldflags.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- ngspice-26/src/xspice/icm/makedefs.in
-+++ ngspice-26/src/xspice/icm/makedefs.in
-@@ -44,16 +44,19 @@
- LIBS = -lm
-
- # Flags to use when linking shared library
--LDFLAGS = -shared
- ifeq ($(ISMINGW), 1)
-- LDFLAGS = -shared @LDFLAGS@
--endif
--ifeq "$(strip $(uname))" "Darwin"
-- LDFLAGS = -bundle -flat_namespace -undefined suppress
--endif
--ifeq "$(strip $(uname))" "SunOS"
-- ifneq "$(CC)" "gcc"
-- LDFLAGS = -G
-+ LDFLAGS += -shared @LDFLAGS@
-+else
-+ ifeq "$(strip $(uname))" "Darwin"
-+ LDFLAGS += -bundle -flat_namespace -undefined suppress
-+ else
-+ ifeq "$(strip $(uname))" "SunOS"
-+ ifneq "$(CC)" "gcc"
-+ LDFLAGS += -G
-+ else
-+ LDFLAGS += -shared
-+ endif
-+ endif
- endif
- endif
-
diff --git a/sci-electronics/ngspice/ngspice-26.ebuild b/sci-electronics/ngspice/ngspice-26.ebuild
deleted file mode 100644
index 3c185422f418..000000000000
--- a/sci-electronics/ngspice/ngspice-26.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="3"
-
-inherit autotools eutils
-
-DESCRIPTION="The Next Generation Spice (Electronic Circuit Simulator)"
-SRC_URI="mirror://sourceforge/ngspice/${P}.tar.gz
- mirror://sourceforge/ngspice/${PN}-${PV}-manual.pdf"
-HOMEPAGE="http://ngspice.sourceforge.net"
-LICENSE="BSD GPL-2"
-
-SLOT="0"
-IUSE="X debug readline"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x64-macos"
-
-DEPEND="sys-libs/ncurses
- readline? ( >=sys-libs/readline-5.0 )
- X? ( x11-libs/libXaw
- x11-libs/libXt
- x11-libs/libX11
- sci-visualization/xgraph )"
-
-RDEPEND="$DEPEND"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-respect-ldflags.patch
- sed -e '/CFLAGS=/s: -s::' -i configure.ac || die "sed failed"
- sed -e 's/_CFLAGS -O2/_CFLAGS/' -i configure.ac || die "sed failed"
- sed -e '/AM_INIT_AUTOMAKE/s:-Werror::' -i configure.ac || die "sed failed"
- # builds also with ncurses[tinfo] (bug #458128)
- sed -e 's/ncurses termcap/ncurses termcap tinfo/g' -i configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- local MYCONF
- if use debug ; then
- MYCONF="--enable-debug \
- --enable-ftedebug \
- --enable-cpdebug \
- --enable-asdebug \
- --enable-stepdebug \
- --enable-pzdebug"
- else
- MYCONF="--disable-debug \
- --disable-ftedebug \
- --disable-cpdebug \
- --disable-asdebug \
- --disable-stepdebug \
- --disable-pzdebug"
- fi
- # Those don't compile
- MYCONF="${MYCONF} \
- --disable-sensdebug \
- --disable-blktmsdebug \
- --disable-smltmsdebug"
-
- econf \
- ${MYCONF} \
- --enable-xspice \
- --enable-cider \
- --enable-ndev \
- --disable-xgraph \
- --disable-dependency-tracking \
- --disable-rpath \
- $(use_with X x) \
- $(use_with readline)
-}
-
-# These will need to be looked at some day:
-# --enable-adms
-# --enable-nodelimiting
-# --enable-predictor
-# --enable-newtrunc
-# --enable-openmp
-
-src_install () {
- local infoFile
- for infoFile in doc/ngspice.info*; do
- echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
- echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
- echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> ${infoFile}
- echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
- done
-
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ANALYSES AUTHORS BUGS ChangeLog DEVICES NEWS \
- README Stuarts_Poly_Notes || die "failed to install documentation"
-
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/${PN}-${PV}-manual.pdf || die "failed to install manual"
-
- # We don't need ngmakeidx to be installed
- rm "${D}"/usr/bin/ngmakeidx
-}
-
-src_test () {
- # Bug 108405
- true
-}