summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/liblas/Manifest1
-rw-r--r--sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch15
-rw-r--r--sci-geosciences/liblas/liblas-1.8.1-r1.ebuild49
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-geosciences/liblas/Manifest b/sci-geosciences/liblas/Manifest
index 118f37d5fa6c..3b20aa193d59 100644
--- a/sci-geosciences/liblas/Manifest
+++ b/sci-geosciences/liblas/Manifest
@@ -1 +1,2 @@
DIST libLAS-1.8.1.tar.bz2 3920203 BLAKE2B 2ef8e822c5d1c07d929e788c59e6e5b942aba637fb764d37e1505d136c75cd4a28efc4702b022bcfee8063b684956b4466c9ec00e737d7024ca2719d7b11f341 SHA512 1cb39c557af0006c54f1100d0d409977fcc1886abd155c1b144d806c47f8675a9f2125d3a9aca16bae65d2aabba84d5e5e322b42085e7db312f3d53f92342acf
+DIST liblas-1.8.1.tar.gz 10734926 BLAKE2B dcd3dc043840857222e6b0a19dcb264ba34c09aa20cda9694ed182e040f9024c0b4a0e2359b1ba0da2337fa5b145aedb9a76a6dcea7ffd7cbcb125d0ae9af399 SHA512 0f8a0460e33c23c8a82eb42ab66ba69d4cc0680f6d320ce429653670f950f5724b88c5870800e0ab000e72cf0c08c55a4c468fe1b244140d867e2cb665f0f0b6
diff --git a/sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch b/sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch
new file mode 100644
index 000000000000..0b77da12148a
--- /dev/null
+++ b/sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch
@@ -0,0 +1,15 @@
+--- a/src/gt_citation.cpp 2018-08-03 12:16:16.007831564 +0100
++++ b/src/gt_citation.cpp 2018-08-03 12:16:45.224830335 +0100
+@@ -387,10 +387,10 @@
+ osCitation += primemName;
+ bRewriteGeogCitation = TRUE;
+
+- double primemValue = poSRS->GetPrimeMeridian(NULL);
++ double primemValue = poSRS->GetPrimeMeridian();
+ if(angUnitName && !EQUAL(angUnitName, "Degree"))
+ {
+- double aUnit = poSRS->GetAngularUnits(NULL);
++ double aUnit = poSRS->GetAngularUnits();
+ primemValue *= aUnit;
+ }
+ GTIFKeySet( psGTIF, GeogPrimeMeridianLongGeoKey, TYPE_DOUBLE, 1,
diff --git a/sci-geosciences/liblas/liblas-1.8.1-r1.ebuild b/sci-geosciences/liblas/liblas-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..8e0dbdea8572
--- /dev/null
+++ b/sci-geosciences/liblas/liblas-1.8.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C/C++ library for manipulating the LAS LiDAR format common in GIS"
+HOMEPAGE="https://github.com/libLAS/libLAS/"
+SRC_URI="https://github.com/libLAS/libLAS/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# tests known to fail due to LD_LIBRARY_PATH issue
+RESTRICT="test"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="gdal"
+
+RDEPEND="
+ dev-libs/boost:=
+ sci-geosciences/laszip
+ sci-libs/libgeotiff
+ gdal? ( sci-libs/gdal )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/libLAS-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.0_remove-std-c++98.patch
+ "${FILESDIR}"/${P}-fix-overload-call.patch #bug 661654
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # add missing linkage
+ sed -e 's:${LAS2COL} ${LIBLAS_C_LIB_NAME}:& ${CMAKE_THREAD_LIBS_INIT}:' \
+ -i "${S}/apps/CMakeLists.txt" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DWITH_GDAL=$(usex gdal)"
+ -DLIBLAS_LIB_SUBDIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}