summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/Shapely/Shapely-9999.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-9999.ebuild b/sci-libs/Shapely/Shapely-9999.ebuild
new file mode 100644
index 000000000000..1b3020d48ddd
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}