summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild')
-rw-r--r--sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
new file mode 100644
index 000000000000..b62af63400b0
--- /dev/null
+++ b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Genetic Algorithm Utility Library"
+HOMEPAGE="http://GAUL.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaul/${P}-0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug slang static-libs"
+
+DEPEND="
+ sys-apps/sed
+ slang? ( sys-libs/slang )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-0
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-slang2-error.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use slang || myconf="--enable-slang=no"
+ if use debug ; then
+ myconf="${myconf} --enable-debug=yes --enable-memory-debug=yes"
+ else
+ myconf="${myconf} --enable-g=no"
+ fi
+ econf $(use_enable static-libs static) ${myconf}
+}
+
+src_install() {
+ MAKEOPTS+=" -j1"
+ default
+}