summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lmfit/lmfit-8.2.2.ebuild')
-rw-r--r--sci-libs/lmfit/lmfit-8.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/lmfit/lmfit-8.2.2.ebuild b/sci-libs/lmfit/lmfit-8.2.2.ebuild
new file mode 100644
index 000000000000..6d1f6b2e4b60
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-8.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINJECT_C_FLAGS=OFF
+ )
+
+ cmake-utils_src_configure
+}