summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/plplot/plplot-5.12.0.ebuild')
-rw-r--r--sci-libs/plplot/plplot-5.12.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-libs/plplot/plplot-5.12.0.ebuild b/sci-libs/plplot/plplot-5.12.0.ebuild
index 5bf49807a6d8..9cf3d800c8c9 100644
--- a/sci-libs/plplot/plplot-5.12.0.ebuild
+++ b/sci-libs/plplot/plplot-5.12.0.ebuild
@@ -9,7 +9,7 @@ FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=95
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils fortran-2 java-pkg-opt-2 python-single-r1 toolchain-funcs virtualx wxwidgets
+inherit cmake-utils flag-o-matic fortran-2 java-pkg-opt-2 python-single-r1 toolchain-funcs virtualx wxwidgets
DESCRIPTION="Multi-language scientific plotting library"
HOMEPAGE="http://plplot.sourceforge.net/"
@@ -138,6 +138,10 @@ src_configure() {
# * Qt4 has been disabled, as it is deprecated and unsupported upstream
# - DPLD_* drivers need to use ON/OFF instead of the usex defaults yes/no, as
# the testsuite performs a string comparison to determine which tests to run
+
+ # Octave bindings now require C++11 support, #609980
+ append-cxxflags -std=c++11
+
local mycmakeargs=(
## Features
-DBUILD_DOC=OFF