summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Shapely/Shapely-1.6.4_p2.ebuild3
-rw-r--r--sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch17
2 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
index 111341b34ff8..107d9d9c717c 100644
--- a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
+++ b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
@@ -31,6 +31,9 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${P}-test_operations.patch" ) # bug 701624
+
S="${WORKDIR}/${PN}-${MY_PV}"
python_prepare_all() {
diff --git a/sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch b/sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch
new file mode 100644
index 000000000000..a9213a333765
--- /dev/null
+++ b/sci-libs/Shapely/files/Shapely-1.6.4_p2-test_operations.patch
@@ -0,0 +1,17 @@
+Description: Mark test_operations as xfail.
+ # Intersection
+ > self.assertIsInstance(point.intersection(Point(-1, -1)),
+ GeometryCollection)
+ E AssertionError: <shapely.geometry.point.Point object at 0xffffb6e2c250> is not an instance of <class 'shapely.geometry.collection.GeometryCollection'>
+Author: Bas Couwenberg <sebastic@debian.org>
+
+--- a/tests/test_operations.py
++++ b/tests/test_operations.py
+@@ -7,6 +7,7 @@ from shapely.geos import TopologicalErro
+
+ class OperationsTestCase(unittest.TestCase):
+
++ @pytest.mark.xfail(reason="Intersection: Point is not an instance of GeometryCollection")
+ def test_operations(self):
+ point = Point(0.0, 0.0)
+