summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/Manifest1
-rw-r--r--sci-libs/hdf5/hdf5-1.10.5.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sci-libs/hdf5/Manifest b/sci-libs/hdf5/Manifest
index 7ec5335c9d8a..e8b5dd2438ce 100644
--- a/sci-libs/hdf5/Manifest
+++ b/sci-libs/hdf5/Manifest
@@ -1,2 +1,3 @@
DIST hdf5-1.10.1.tar.bz2 11769617 BLAKE2B 66ad762aed90cea9e58a9735bf0e189d78befc40cac0e566586e967f2b3ba6f5bf8a6bfd12a2f4062f8b20900c16d467c34134c17dedfd8f345cb96bd853a2fe SHA512 266b0e2f28c5fd540099a4955244ddb8c03aca3ad40d626358643f033a6ae5e9266a1d6c1d60925c7d42d24d28a1549d3305fe8ddb42cec2379af7231b93e554
+DIST hdf5-1.10.5.tar.bz2 8706317 BLAKE2B ac326be8fe4ccc4b0153f15bc7d65aa8f1adc2ae279d3980f57ed46722b754d3f36ecf1d6273c75e80ed1afd4bbf10c6b1c5d9408e1f83a4b2e397e7902a7d3c SHA512 769e43b8672e26fe24ed68da0228c010d3d9bc950ca09f0bc60707911a2f26f2f8415c8abc8ec06e07667148d8cdb3b0c7b3e7860d9b19739629c5dfd5ce73d4
DIST hdf5-1.8.18.tar.bz2 10081294 BLAKE2B cf0d0c8a41576bcf816460eaabcfab29cfffba240721a64fe584c42fbb322470f29fb93c8513f7bbdedeeb392c2fe64cd3261b47b47de5b01828dae0b1929cd3 SHA512 01f6d14bdd3be2ced9c63cc9e1820cd7ea11db649ff9f3a3055c18c4b0fffe777fd23baad536e3bce31c4d76fe17db64a3972762e1bb4d232927c1ca140e72b2
diff --git a/sci-libs/hdf5/hdf5-1.10.5.ebuild b/sci-libs/hdf5/hdf5-1.10.5.ebuild
new file mode 100644
index 000000000000..1e8158a6d6bd
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.10.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs multilib prefix
+
+MY_P=${PN}-${PV/_p/-patch}
+MAJOR_P=${PN}-$(ver_cut 1-2)
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran +hl mpi static-libs szip threads zlib"
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran !hl )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( virtual/szip )
+ zlib? ( sys-libs/zlib:0= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2
+ >=sys-devel/autoconf-2.69"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ "${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
+)
+
+pkg_setup() {
+ tc-export CXX CC AR # workaround for bug 285148
+ use fortran && fortran-2_pkg_setup
+
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ if ! use examples; then
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die #409091
+ fi
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/src/misc/h5cc.in || die
+ hprefixify m4/libtool.m4
+
+ default
+ eautomake
+}
+
+src_configure() {
+ econf \
+ --enable-deprecated-symbols \
+ $(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production) \
+ $(use_enable debug codestack) \
+ $(use_enable cxx) \
+ $(use_enable fortran) \
+ $(use_enable hl) \
+ $(use_enable mpi parallel) \
+ $(use_enable threads threadsafe) \
+ $(use_with szip szlib) \
+ $(use_with threads pthread) \
+ $(use_with zlib)
+}